zoukankan      html  css  js  c++  java
  • [ACM] hdu Lifting the Stone(多边形的重心)

    Problem Description

    There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.

    Input

    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.

    Output

    Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.

    Sample Input

    2
    4
    5 0
    0 5
    -5 0
    0 -5
    4
    1 1
    11 1
    11 11
    1 11
    

    Sample Output

    0.00 0.00
    6.00 6.00
    

    Source

    Central Europe 1999

    模板:

    struct point
    {
        double x,y;
    };
    point data[maxn];
    
    point gravity(point po[],int n)//求重心
    {
        point p,s;;
        double tp,area=0,tpx=0,tpy=0;
        p.x=po[0].x;p.y=po[0].y;
        for(int i=1;i<=n;i++)
        {
            s.x=po[(i==n)?0:i].x;
            s.y=po[(i==n)?0:i].y;
            tp=p.x*s.y-s.x*p.y;
            area+=tp/2.0;
            tpx+=(p.x+s.x)*tp;
            tpy+=(p.y+s.y)*tp;
            p.x=s.x;
            p.y=s.y;
        }
        s.x=tpx/(6*area);
        s.y=tpy/(6*area);
        return s;
    }
    


    本题代码:

    #include <iostream>
    #include <iomanip>
    using namespace std;
    const int maxn=1000002;
    
    struct point
    {
        double x,y;
    };
    point data[maxn];
    
    point gravity(point po[],int n)//求重心
    {
        point p,s;;
        double tp,area=0,tpx=0,tpy=0;
        p.x=po[0].x;p.y=po[0].y;
        for(int i=1;i<=n;i++)
        {
            s.x=po[(i==n)?0:i].x;
            s.y=po[(i==n)?0:i].y;
            tp=p.x*s.y-s.x*p.y;
            area+=tp/2.0;
            tpx+=(p.x+s.x)*tp;
            tpy+=(p.y+s.y)*tp;
            p.x=s.x;
            p.y=s.y;
        }
        s.x=tpx/(6*area);
        s.y=tpy/(6*area);
        return s;
    }
    
    int main()
    {
        int t,n;
        cin>>t;
        for(int ti=1;ti<=t;ti++)
        {
            cin>>n;
            for(int i=0;i<n;i++)
                cin>>data[i].x>>data[i].y;
            point temp=gravity(data,n);
            cout<<setiosflags(ios::fixed)<<setprecision(2)<<temp.x<<" "<<temp.y<<endl;
        }
        return 0;
    }
    


     

  • 相关阅读:
    Ionic Tabs
    Ionic实战九:ionic视频播放
    Ionic实战八:ionic登陆页面源码
    Ionic实战七:Ionic 音乐以及社交页面
    Ionic实战六:日期选择控件
    Ionic实战五:ionic图表源码基于highcharts
    Ionic实战四:ionic 即时通讯_ionic仿雅虎邮箱
    Ionic实战三:Ionic 图片预览可放大缩小左右滑动demo-iClub图片预览
    Ionic实战二:购物车
    编译错误总汇
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697789.html
Copyright © 2011-2022 走看看