zoukankan      html  css  js  c++  java
  • [ACM

    Problem Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

    Input

    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

    Output

    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0 
    

    Sample Output

    0
    1
    2
    2
    

    Source

    Mid-Central USA 1997

    解题思路:

    这题没有看解题报告,自己折腾出来的。虽然这题比较简单,但做完后,对Dfs(有了一定的认识,Dfs函数里面包含递归函数,而且把满足返回条件的语句写在最前面,还有对当前变量赋值什么的也写在最前面(把搜索过的地方换成别的变量,标记,避免重复搜索)。本题中DFS搜索了几次,就有几个满足题目要求的Oil Deposits。

    代码:

    #include <iostream>
    using namespace std;
    
    char s[102][102];
    int m,n;
    int i,j;
    
    void dfs(int x,int y)
    {
        if(x<1||x>m||y<1||y>n)
            return  ;
        if(s[x][y]!='@')
            return ;  //把一些返回条件写到最前面
             s[x][y]='*';
        for(int i=-1;i<=1;i++)
            for(int j=-1;j<=1;j++) //8个方向
        {
            dfs(x+i,y+j);
        }
    }
    int main()
    {
        while(cin>>m>>n&&m)
        {
            int c=0;
            for(i=1;i<=m;++i)
                for(j=1;j<=n;j++)
                cin>>s[i][j];
    
            for(i=1;i<=m;++i)
                for(j=1;j<=n;++j)
            {
                if(s[i][j]=='@')
                {
                    dfs(i,j);//深搜
                    c++;//DFS了多少次,就有多少个
                }
            }
            cout<<c<<endl;
        }
    }
    


    运行截图:

  • 相关阅读:
    [课程设计]Scrum 1.6 多鱼点餐系统开发进度
    [课程设计]Scrum 1.7 多鱼点餐系统开发进度
    [课程设计]Scrum 1.5 多鱼点餐系统开发进度
    [课程设计]Scrum 1.4 多鱼点餐系统开发进度
    [课程设计]Scrum 1.3 多鱼点餐系统开发进度
    [课程设计]Scrum 1.2 Spring 计划&系统流程&DayOne燃尽图
    [课程设计]Scrum 1.1 NABCD模型&产品Backlog
    [课程设计]Scrum团队分工及明确任务1.0 ----多鱼点餐
    学习进度条
    [课程设计]多鱼点餐系统个人总结
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697816.html
Copyright © 2011-2022 走看看