zoukankan      html  css  js  c++  java
  • [ACM]The 3n + 1 problem

    Problem Description
    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    Consider the following algorithm: 


        1.      input n

        2.      print n

        3.      if n = 1 then STOP

        4.           if n is odd then n <- 3n + 1

        5.           else n <- n / 2

        6.      GOTO 2


    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

    Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
     

    Input
    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

    You can assume that no opperation overflows a 32-bit integer.
     

    Output
    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 
     

    Sample Input
    1 10 100 200 201 210 900 1000
     

    Sample Output
    1 10 20 100 200 125 201 210 89 900 1000 174
     

    Source


    解题思路:

    每一个数都有一个序列(以1结束),题目要求是输入两个数 i ,j ,输出的是从i到j (包括他们)之间所有数序列的最大长度。外部用一层循环就可以了,根据所给的运算法则对每一个数进行运算,每一次循环都用count来记录当前数的序列长度。

    代码:

    #include <iostream>
    using namespace std;
    int main()
    {
        int i,j;
        while(cin>>i>>j)
        {
           int tempi,tempj;
           tempi=i;tempj=j;
           int max=0;
           tempi=(i<=j)?i:j;//把i,j中小的数给tempi
           tempj=(i>=j)?i:j;
           for(;tempi<=tempj;tempi++)
           {
               int tempii//定义这个变量很关键,因为每一次循环过程中,tempi的值都不能改变,用tempii来代替tempi,进行运算法则运算,这样不会破坏外层循环的连续性。
               int count;
               count=1;
               tempii=tempi;
               while(tempii!=1)
               {
                   if(tempii%2==0)
                    {
                        tempii=tempii/2;
                        count++;
                    }
                    else
                    {
                        tempii=3*tempii+1;
                        count++;
                    }
               }
               if(max<=count)
                max=count;
           }
           cout<<i<<" "<<j<<" "<<max<<endl;
        }
        return 0;
    }
    

    运行结果:


  • 相关阅读:
    HihoCoder 1245:王胖浩与三角形 三角形边长与面积
    C++ 读写注册表
    Codestorm:Counting Triangles 查各种三角形的个数
    2015年10月之 叽里咕噜
    HDU 5523:Game
    Codestorm:Game with a Boomerang
    关于GPU-driver for linux的资料
    ACER NV47H75C 安装CUDA 驱动以及调整屏幕
    服务器GTX590安装CUDA
    观后感,读了几篇博文
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697832.html
Copyright © 2011-2022 走看看