zoukankan      html  css  js  c++  java
  • [ACM]A Mathematical Curiosity

    Problem Description
    Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     

    Input
    You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
     

    Output
    For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
     

    Sample Input
    1 10 1 20 3 30 4 0 0
     

    Sample Output
    Case 1: 2 Case 2: 4 Case 3: 5
     

    Source


    解题思路:枚举。


    代码:

    #include <iostream>
    #include <cmath>
    using namespace std;
    int main()
    {
        int N,n,m,Case,count;
        int Ni,a,b;
        cin>>N;
        for(Ni=0;Ni<N;Ni++)
        {
            Case=1;
            while(cin>>n>>m&&(n||m))//这个条件要特别注意
            {
                count=0;
                for(a=1;a<n;++a)
                    for(b=a+1;b<n;++b)
                {
                    //判断一个数是否为整数的第一种方法
                    if((a*a+b*b+m)%(a*b)==0)
                        count++;
    
                    //第二种方法
    
                    /*float temp;
                    temp=(a*a+b*b+m)/(a*b*10.0)*10.0;
                    if(temp-int(temp)==0)
                        count++;*/
    
                    //第三种方法
    
                    /*float temp;
                    temp=(a*a+b*b+m)/(a*b*10.0)*10.0;
                    if(floor(temp+0.5)==temp)
                        count++;*/
                }
                cout<<"Case "<<Case<<": "<<count<<endl;
                Case++;
            }
            if(Ni<N-1)
                cout<<endl;
        }
        return 0;
    }
    


    误区:这个题目看起来很简单,但有一个小细节也会让你提交N遍也是Wrong Answer,就是那个while(cin>>n>>m&&(n||m))里面的条件,是&&(n||m) 而不是&&n&&m,正是因为这个小条件弄错了,郁闷的我快抓破了头皮,前者的意思是 n和m不能同时为0,m可以为0,后者的意思是n和m都不能等于0,而题目的意思是n不能等于0,但m可以等于0.  哎!教训啊!

    运行截图:




  • 相关阅读:
    各种基础网络的通道数及尺寸问题记录
    LPRnet轻量级实时车牌识别,主网络代码以及论文思路简要介绍
    python保存字符串到txt文件
    python删除目录下文件大小小于某个值的方法
    pyqt5注意事项
    github上传项目,更新项目
    python删除一个目录下某个类型的文件,以及删除目录下子目录的所有文件
    redis批量删除key
    mongodb常用操作
    curl参数为List<实体类>的请求方式
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697833.html
Copyright © 2011-2022 走看看