zoukankan      html  css  js  c++  java
  • [ACM] poj 2484 A Funny Game(对称博弈)

    A Funny Game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3795   Accepted: 2268

    Description

    Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 106) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)

    Figure 1

    Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)

    Suppose that both Alice and Bob do their best in the game.
    You are to write a program to determine who will finally win the game.

    Input

    There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

    Output

    For each test case, if Alice win the game,output "Alice", otherwise output "Bob".

    Sample Input

    1
    2
    3
    0
    

    Sample Output

    Alice
    Alice
    Bob

    Source

    POJ Contest,Author:Mathematica@ZSU

    解题思路:

    对于n<=2,先手ALICE必胜。n>3时,无论Alice怎么取,BOB都可以取一定的数目来构造出中心对称,这样BOB一定是最后一次取光的。

    代码:

    #include <iostream>
    using namespace std;
    
    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            if(n>2)
                cout<<"Bob"<<endl;
            else
                cout<<"Alice"<<endl;
        }
        return 0;
    }
    


     

  • 相关阅读:
    如何 Xcode 开发工具里安装一个空的项目末模板
    推荐完成项目要使用的常用工具
    仿照 QQ 的 cell 的左滑删除、置顶、标记未读效果
    API接口文档的撰写
    UI:动画
    UI:多线程 、用GCD创建线程
    UI:UICollectionView
    开发中的一些零碎知识点
    UI:数据库练习、滤镜效果
    UI:地图和定位
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697919.html
Copyright © 2011-2022 走看看