zoukankan      html  css  js  c++  java
  • [ACM] hdu 1114 Piggy-Bank(完全背包)

    Piggy-Bank

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9921    Accepted Submission(s): 4997


    Problem Description
    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
     


     

    Input
    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
     


     

    Output
    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
     


     

    Sample Input
    3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
     


     

    Sample Output
    The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
     


     

    Source

    解题:

    纯粹的完全背包。不过本题要求最小值,初始化无穷大。

    代码:

    #include <iostream>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    
    int dp[10002];
    int v[502];
    int w[502];
    int N,V;
    const int inf=100000000;//作为无穷大
    
    void solve()//完全背包实现
    {
        for(int i=0;i<=V;i++)
            dp[i]=inf;
        dp[0]=0;//别忘了这一行
        for(int i=0;i<N;i++)
            for(int j=w[i];j<=V;j++)
            dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
    }
    
    int main()
    {
        int t;cin>>t;
        while(t--)
        {
            int a,b;
            cin>>a>>b;
            V=b-a;
            cin>>N;
            for(int i=0;i<N;i++)
                cin>>v[i]>>w[i];
            solve();
            if(dp[V]!=inf)
                cout<<"The minimum amount of money in the piggy-bank is "<<dp[V]<<"."<<endl;
            else
                cout<<"This is impossible."<<endl;
        }
        return 0;
    }
    


    运行:

  • 相关阅读:
    从 QSplitter 中移除 QWidget(使用隐藏与显示,切换十分方便,不要真正销毁)
    Qt虽然自己的源代码里不使用Exception,但也提供了一个QException及其子类QUnhandledException
    细说new与malloc的10点区别
    垃圾回收算法
    服务追踪数据使用 RabbitMQ 进行采集 + 数据存储使用 Elasticsearch + 数据展示使用 Kibana
    缓存穿透、缓存击穿与缓存雪崩
    微服务介绍
    分库分表
    Spring Boot、微服务架构和大数据
    Linux基本的操作
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697943.html
Copyright © 2011-2022 走看看