zoukankan      html  css  js  c++  java
  • 洛谷P2886 [USACO07NOV]牛继电器Cow Relays

    题目描述

    For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

    Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi  ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

    To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

    Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

    给出一张无向连通图,求S到E经过k条边的最短路。

    输入输出格式

    输入格式:

    * Line 1: Four space-separated integers: N, T, S, and E

    * Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

    输出格式:

    * Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

    输入输出样例

    输入样例#1: 复制
    2 6 6 4
    11 4 6
    4 4 8
    8 4 9
    6 6 8
    2 6 9
    3 8 9
    输出样例#1: 复制
    10

    题解:
    一句话题意:给出一个有t条边的图,求从s到e恰好经过k条边的最短路。
    a:是图的邻接矩阵,f是图中任意两点直接的最短距离、

    floyd算法:
    f[i][j]=min(f[i][j],f[i][k]+f[k][j]);
    一遍floyed后: f[i][j]ij的最短距离:中间至少1条边(连通图),最多n-1条边
    floyd算法的变形:
    a:是图的邻接矩阵,a[i][j]是经过一条边的最短路径。f[i][j]k的初值为∞

    f[i][j]-1=∞;
    f[i][j]1=a;    //经过一条边的最短路径
    f[i][j]2=min(f[i][j]2,a[i][k]+a[k][j])=a*a=a2;//经过二条边的最短路径,经过一次floyd.矩阵相乘一次,f[i][j]2初值为∞。
    f[i][j]3=min(f[i][j]3,f[i][k]2+a[k][j])=a*a*a=a3;//经过三条边的最短路径,经过二次floyd。f[i][j]3初值为∞
    f[i][j]4=min(f[i][j]4,f[i][k]3+a[k][j])=a4;//经过四条边的最短路径,经过三次floyd,f[i][j]4初值为∞

        ...

    f[i][j]k=min(f[i][j]k,f[i][k]k-1+a[k][j])=ak;//经过k条边的最短路径,经过K-1次floyd,f[i][j]k初值为∞

    而floyd的时间复杂度为O(n3),则从的时间复杂度为O(Kn3),非常容易超时。
    所以我们可以用快速幂来完成。
    f[i][j]r+p=min(f[i][j]r+p,f[i][k]r+f[k][j]p)
    程序:
    //洛谷2886 
    //(1)对角线不能设置为0,否则容易自循环。(2)数组要放在主程序外面 
    //(3)K条边,不一定是最简路 
    #include<iostream>
    #include<cstdio>
    #include<map>
    #include<cstring>
    using namespace std;
    map<int,int>f;
    const int maxn=210;
    int k,t,s,e,n;
    int a[maxn][maxn];
    struct Matrix{
        int b[maxn][maxn];
    };
    Matrix A,S;
    Matrix operator *(Matrix A,Matrix B){//运算符重载 
        Matrix c;
        memset(c.b,127/3,sizeof(c.b) );
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    c.b[i][j]=min(c.b[i][j],A.b[i][k]+B.b[k][j]);
        return c;
    }
    Matrix power(Matrix A,int k){
        if(k==0) return A;
        Matrix S=A;
        for(int i=1;i<=n;i++){
                for (int j=1;j<=n;j++)
                    cout<<A.b[i][j]<<" ";
                cout<<endl;
            }
            cout<<endl;
        while(k){
            if(k&1)S=S*A;//奇数执行,偶数不执行 
            /*cout<<k<<":"<<endl;
                for(int i=1;i<=n;i++){
                for (int j=1;j<=n;j++)
                    cout<<S.b[i][j]<<" ";
                cout<<endl;
            }*/
            cout<<endl;
            A=A*A;
            k=k>>1;
        
        }
        return S;
    }
    int main(){
        cin>>k>>t>>s>>e;
        int w,x,y;
        memset(A.b,127/3,sizeof(A.b) );// 赋初值
        n=0;
        for(int i=1;i<=t;i++){//t<100,x<1000  点不是从1开始的,可以用map离散化,给点从1开始编号。n记录共有多少个点。 
            cin>>w>>x>>y;
            if (f[x]==0)    f[x]=++n;
            if (f[y]==0)    f[y]=++n;
            A.b[f[x]][f[y]]=A.b[f[y]][f[x]]=min(w,A.b[f[y]][f[x]]);
        }
        S=power(A,k-1);//快速幂.执行k-1次floyd矩阵乘
        s=f[s];
        e=f[e];
        
        cout<<S.b[s][e];
        return 0;
    }


  • 相关阅读:
    MS CRM 2011插件调试工具
    MSCRM 相關 (到石頭居博客查看)
    es6 复习
    HTML阶段笔试题附答案
    CSS选择器
    jQuery 效果知识总结
    markdown基本语法
    HTML5给我们带来了什么?
    H5新增语义化标签
    c#中去掉字符串空格方法
  • 原文地址:https://www.cnblogs.com/ssfzmfy/p/10740803.html
Copyright © 2011-2022 走看看