zoukankan      html  css  js  c++  java
  • POJ 2352 Stars *树状数组

    Stars

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 20   Accepted Submission(s) : 14

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

    Sample Input

    5
    1 1
    5 1
    7 1
    3 3
    5 5

    Sample Output

    1
    2
    1
    1
    0

    Source

    Ural Collegiate Programming Contest 1999
    /*
    POJ 2352 Stars
    就是求每个小星星左小角的星星的个数。坐标按照Y升序,Y相同X升序的顺序给出
    由于y轴已经排好序,可以按照x坐标建立一维树状数组
    */
    
    #include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    int ans[15005];   //统计数组
    int tree[32005];  //树状数组
    int i,n,x,y,t,num;
    
    int lowbit(int k)
    {
        return k&(-k);
    }
    
    int sum(int i)
    {
        int s=0;
        while (i>0)
        {
          s=s+tree[i];
          i=i-lowbit(i);
        }
        return s;
    }
    void add(int i,int val)
    {
        while(i<=32000)
        {
            tree[i]=tree[i]+val;
            i=i+lowbit(i);
        }
        return;
    }
    int main()
    {
        while(~scanf("%d",&n))
        {
            memset(tree,0,sizeof(tree));
            memset(ans,0,sizeof(ans));
            for(i=1;i<=n;i++)
            {
                scanf("%d%d",&x,&y);
                num=sum(x+1);
                ans[num]++;
                add(x+1,1);
            }
            for(i=0;i<=n-1;i++)
                printf("%d\n",ans[i]);
        }
        return 0;
    }
    

      

  • 相关阅读:
    《构建之法》阅读笔记4
    《构建之法》阅读笔记3
    《构建之法》阅读笔记2
    《构建之法》阅读笔记1
    Android可折叠式菜单栏
    Material卡片式布局+下拉刷新+完整代码
    android悬浮按钮的使用
    androidStdio下载与安装以及安装过程问题解释
    html给图片划分区域添加链接
    UI进阶2-滑动菜单
  • 原文地址:https://www.cnblogs.com/stepping/p/5513314.html
Copyright © 2011-2022 走看看