zoukankan      html  css  js  c++  java
  • HDU 1010 Temper of the bone(深搜+剪枝)

    Tempter of the Bone

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 15   Accepted Submission(s) : 9

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

    Input

    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

    'X': a block of wall, which the doggie cannot enter; 
    'S': the start point of the doggie; 
    'D': the Door; or
    '.': an empty block.

    The input is terminated with three 0's. This test case is not to be processed.

    Output

    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

    Sample Input

    4 4 5
    S.X.
    ..X.
    ..XD
    ....
    3 4 5
    S.X.
    ..X.
    ...D
    0 0 0
    

    Sample Output

    NO
    YES
    

    Author

    ZHANG, Zheng

    Source

    ZJCPC2004
    #include <iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    using namespace std;
    int dr[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
    int f[10][10];
    char mp[10][10];
    int sx,sy,tx,ty,t,n,m,i,j;
    int check(int x,int y)
    {
        if (x>=0 && x<n && y>=0 && y<m && mp[x][y]!='X' && !f[x][y]) return 1;
          else return 0;
    }
    int  dfs(int x,int y,int time)
    {
        if (time==0 && x==tx && y==ty)
               return 1;
        for(int i=0;i<4;i++)
        {
            int xx=x+dr[i][0];
            int yy=y+dr[i][1];
            if (check(xx,yy))
            {
                f[xx][yy]=1;
                if (dfs(xx,yy,time-1)) return 1;
                f[xx][yy]=0;
            }
        }
        return 0;
    }
    
    int main()
    {
        while(scanf("%d%d%d",&n,&m,&t) && n!=0)
        {
            for(i=0;i<n;i++)
                {
                    scanf("%s",&mp[i]);
                    for(j=0;j<m;j++)
                        if (mp[i][j]=='S') sx=i,sy=j;
                           else if (mp[i][j]=='D') tx=i,ty=j;
                }
           if (t==0)
           {
                if (sx!=tx && sy!=ty) printf("NO\n");
                  else if (sx==tx && sy==ty) printf("YES\n");
                continue;
           }
           if (abs(tx-sx)+abs(ty-sy)>t || (t-abs(tx-sx)-abs(ty-sy))%2!=0) {printf("NO\n");continue;}
    
           memset(f,0,sizeof(f));
           f[sx][sy]=1;
           if (dfs(sx,sy,t)) printf("YES\n");
                    else printf("NO\n");
        }
    
        return 0;
    }
  • 相关阅读:
    解决IE8不兼容通过class名获取元素的方法
    移动端页面遇到过的各种坑
    强大的正则表达式
    弹性盒子布局
    vue环境搭建
    fullpage.js使用指南
    ES5原生api(1)
    双色球中奖率分析(python)
    使用python脚本的3D引擎Panda3d
    Python lambda介绍
  • 原文地址:https://www.cnblogs.com/stepping/p/5635867.html
Copyright © 2011-2022 走看看