zoukankan      html  css  js  c++  java
  • hdu 1078 FatMouse and Cheese(记忆化搜索)

    FatMouse and Cheese

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 5   Accepted Submission(s) : 5

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

    Input

    There are several test cases. Each test case consists of 

    a line containing two integers between 1 and 100: n and k 
    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
    The input ends with a pair of -1's. 

    Output

    For each test case output in a line the single integer giving the number of blocks of cheese collected. 

    Sample Input

    3 1
    1 2 5
    10 11 6
    12 12 7
    -1 -1
    

    Sample Output

    37
    

    Source

    Zhejiang University Training Contest 2001
    #include <iostream>
    #include<cstring>
    #include<algorithm>
    #include<cstdio>
    using namespace std;
    int f[101][101],a[101][101];
    int n,k,i,j;
    int dr[4][2]={{1,0},{0,1},{-1,0},{0,-1} };
    
    int dfs(int x,int y)
    {
        int ans=0;
      if(!f[x][y])
      {
          for(int i=0;i<4;i++)
            for(int j=1;j<=k;j++)
          {
              int xx=x+dr[i][0]*j;
              int yy=y+dr[i][1]*j;
              if (xx<1 || xx>n || yy<1 || yy>n) continue;
              if (a[xx][yy]<=a[x][y]) continue;
             // ans=max(ans,dfs(xx,yy));
              f[x][y]=max(f[x][y],dfs(xx,yy));
          }
          f[x][y]+=a[x][y];
         // f[x][y]=ans+a[x][y];
      }
      return f[x][y];
    }
    int main()
    {
        while(scanf("%d%d",&n,&k) && n!=-1)
        {
            for(i=1;i<=n;i++)
                for(j=1;j<=n;j++)
                        scanf("%d",&a[i][j]);
            memset(f,0,sizeof(f));
            //ans=0;
            printf("%d\n",dfs(1,1));
        }
        return 0;
    }
  • 相关阅读:
    如何实现清浮动(转载)
    js动态删除某一行,内容超出单元格后超出的部分用省略号代替
    jquery页面隐藏和展开之间切换
    比较jquery中的after(),append(),appendTo()方法
    如何使用git管理代码
    网页游戏常见外挂原理及防御
    JQuery实现页面刷新后菜单保留鼠标点击addclass的样式
    【查询】—Entity Framework实例详解
    SQL Server清除连接过的服务器名称列表
    WebBrowser.ExecWB的完整说明
  • 原文地址:https://www.cnblogs.com/stepping/p/5648439.html
Copyright © 2011-2022 走看看