zoukankan      html  css  js  c++  java
  • HDU1896Stones(优先队列)

    Stones

    Time Limit : 5000/3000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
    Total Submission(s) : 37   Accepted Submission(s) : 30

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
    There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 

    Input

    In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
    For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

    Output

    Just output one line for one test case, as described in the Description.

    Sample Input

    2
    2
    1 5
    2 4
    2
    1 5
    6 6
    

    Sample Output

    11
    12
    #include <iostream>
    #include<queue>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    
    int i,t,n,k;
    
    struct node
    {
        int p,d;
    };
    struct cmp
    {
        bool operator()(node a,node b)
        {
            if (a.p==b.p) return a.d>b.d;
              else return a.p>b.p;
        }
    };
    
    int main()
    {
    
        scanf("%d",&t);
        for(;t>0;t--)
        {
             priority_queue<node,vector<node>,cmp> s;
            scanf("%d",&n);
            node w;
            for(i=1;i<=n;i++)
            {
                scanf("%d%d",&w.p,&w.d);
                s.push(w);
            }
            k=0;
            while(!s.empty())
            {
               w=s.top();
               s.pop();
               k++;
               if (k%2!=0)
               {
                    w.p+=w.d;
                    s.push(w);
               }
            }
            printf("%d\n",w.p);
        }
        return 0;
    }
  • 相关阅读:
    tomcat虚拟机配置
    日期时分秒毫秒+3位随机数
    springmvc action访问路径不带项目名
    nginx 配置模板
    AES加密
    spring-mvc里的 <mvc:resources> 及静态资源访问
    MySQL——事务(Transaction)
    mysql索引
    < aop:aspect>与< aop:advisor>的区别
    annotation-driven
  • 原文地址:https://www.cnblogs.com/stepping/p/5669066.html
Copyright © 2011-2022 走看看