zoukankan      html  css  js  c++  java
  • POJ 1035 Spell checker

    Spell checker
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 24135   Accepted: 8789

    Description

    You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
    If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
    ?deleting of one letter from the word; 
    ?replacing of one letter in the word with an arbitrary letter; 
    ?inserting of one arbitrary letter into the word. 
    Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

    Input

    The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
    The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
    All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

    Output

    Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

    Sample Input

    i
    is
    has
    have
    be
    my
    more
    contest
    me
    too
    if
    award
    #
    me
    aware
    m
    contest
    hav
    oo
    or
    i
    fi
    mre
    #

    Sample Output

    me is correct
    aware: award
    m: i my me
    contest is correct
    hav: has have
    oo: too
    or:
    i is correct
    fi: i
    mre: more me
    #include <iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int i,j,n;
    char ch[10002][20];
    char str[20];
    
    bool ok(int i)
    {
        int l=strlen(ch[i]);
        for(int j=0;j<l;j++)
            if (ch[i][j]!=str[j]) return 0;
        return 1;
    }
    
    int main()
    {
        n=0;
        while(scanf("%s",&ch[++n]))
        {
            if (ch[n][0]=='#') break;
        }
        n--;
        while(scanf("%s",&str))
        {
            if (str[0]=='#') break;
            int l2=strlen(str);
    
            int flag=0;
            for(i=1;i<=n;i++)
            {
               int l1=strlen(ch[i]);
               if(l1==l2 && ok(i))
               {
                   printf("%s is correct\n",str);
                   flag=1;
                   break;
               }
            }
            if (flag) continue;
            printf("%s:",str);
    
              for(i=1;i<=n;i++)
              {
                   int l1=strlen(ch[i]);
                   if (l1==l2-1)//删除
                   {
                       int tflag=0,k=0;
                       for(j=0;j<l1;j++)
                       {
                          if (str[k]==ch[i][j]) k++;
                           else
                           {
                               tflag++;
                               if (str[k+1]!=ch[i][j])
                                   {tflag=2; break;}
                                else  k=k+2;
                           }
                       }
                      if (tflag<2) printf(" %s",ch[i]);  //若不同在最后
                   }
    
                   if (l1==l2) //替换
                   {
                       int tflag=0,k=0;
                       for(j=0;j<l1;j++)
                       {
                          if (str[k]!=ch[i][j]) tflag++;
                            k++;
                       }
                      if (tflag==1) printf(" %s",ch[i]);
                   }
    
    
               if (l1==l2+1)//插入
               {
                   int tflag=0,k=0;
                   for(j=0;j<l1;j++)
                   {
                      if (str[k]==ch[i][j]) k++;
                       else
                       {
                           tflag++;
                           if (str[k]!=ch[i][j+1])
                               {tflag=2; break;}
                       }
                   }
                  if (tflag<2) printf(" %s",ch[i]);//若不同在最后tflag=0
               }
    
              }
            printf("\n");
        }
    
    
        return 0;
    }
  • 相关阅读:
    Lock接口、AbstractQueuedSynchronizer队列同步器、重入锁、读写锁
    SpringMVC一点简单地源码解析
    MyBatis源码部分简单地解析
    笔记本外接显示器不显示
    WPF查找指定类型的父/子控件
    java.io.EOFException: HttpConnectionOverHTTP
    Spark读取HDFS某个路径下的子文件夹中的所有文件
    utf-8 BOM前导3个字节头
    org.apache.hadoop.yarn.exceptions.InvalidAuxServiceException: The auxService:spark_shuffle does not exist
    org.apache.spark.sql.AnalysisException: Table or view not found解决办法
  • 原文地址:https://www.cnblogs.com/stepping/p/5673961.html
Copyright © 2011-2022 走看看