zoukankan      html  css  js  c++  java
  • hdu 2822 Dogs

    Dogs

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 8   Accepted Submission(s) : 2

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim's), So he turn to you for help to point out how could him dig as less as he could.

    We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0) aim at his friend's home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and the up left corner is labeled as ( 1, 1 ).

    Input

    The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with 'X' stands for the lattices of house, and '.' stands for the empty land. The following two lines is the start and end places' coordinates, we guarantee that they are located at 'X'. There will be a blank line between every test case. The block where both two numbers in the first line are equal to zero denotes the end of the input.

    Output

    For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.

    Sample Input

    6 6
    ..X...
    XXX.X.
    ....X.
    X.....
    X.....
    X.X...
    3 5
    6 3
    
    0 0
    

    Sample Output

    3
    

    Hint

    Hint: Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).

    Source

    2009 Multi-University Training Contest 1 - Host by TJU
    思路: 采用优先队列,哪个点时间少哪个点先处理
    #include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<queue>
    using namespace std;
    int n,m,i,j,sx,sy,tx,ty;
    char mp[1005][1005];
    bool vis[1005][1005];  //int爆内存,用bool型
    
    struct node
    {
        int x,y,ti;
        node(int a,int b,int c){x=a;y=b;ti=c;}
    };
    int dr[4][2]={{1,0},{-1,0},{0,1},{0,-1} };
    struct cmp
    {
        bool operator()(node a,node b)
        {
            return a.ti>b.ti;
        }
    };
    bool check(int x,int y)
    {
        if(x>=0 && x<n && y>=0 && y<m && !vis[x][y])  return 1;
         return 0;
    }
    int bfs()
    {
        priority_queue<node,vector<node>,cmp> Q;
        Q.push(node(sx,sy,0));
        vis[sx][sy]=1;
        while(!Q.empty())
        {
            node p=Q.top();
            Q.pop();
           for(int i=0;i<4;i++)
           {
               int xx=p.x+dr[i][0];
               int yy=p.y+dr[i][1];
               if(!check(xx,yy)) continue;
               vis[xx][yy]=1;
               int ti=0;
               if (mp[xx][yy]=='X') ti=p.ti;
                      else ti=p.ti+1;
                 Q.push(node(xx,yy,ti));
               if (xx==tx && yy==ty) return ti;
           }
        }
    }
    int main()
    {
        while(scanf("%d%d",&n,&m))
        {
            if(n==0 && m==0) break;//以0 0 结束
            for(i=0;i<n;i++)
             scanf("%s",&mp[i]);
                scanf("%d%d",&sx,&sy);
                scanf("%d%d",&tx,&ty);
                sx--;
                sy--;
                tx--;
                ty--;
                memset(vis,0,sizeof(vis));
                if (sx==tx && sy==ty) printf("0\n");
                            else  printf("%d\n",bfs());
        }
    
        return 0;
    }
  • 相关阅读:
    关于 HTML5 的 11 个让人难以接受的事实
    【转】zookeeper 的监控工具
    arm+linux 裸机环境搭建之安装工具篇(eclipse)
    Unity 利用NGUI2.6.3做技能冷却的CD效果
    spring boot打包文件后,报错No such file or directory
    机器学习实战读书笔记(3)朴素贝叶斯
    机器学习实战读书笔记(2)决策树
    机器学习实战读书笔记(1)
    No operations allowed after connection closed--转
    简单理解Socket
  • 原文地址:https://www.cnblogs.com/stepping/p/5679290.html
Copyright © 2011-2022 走看看