zoukankan      html  css  js  c++  java
  • ZOJ 2476 Total Amount

    ZOJ 2476 Total Amount

    Time Limit: 2 Sec  Memory Limit: 128 MB

    Submit: 13  Solved: 6

    [Submit][Status][Web Board]

    Description

    Given a list of monetary amounts in a standard format, please calculate the total amount.

    We define the format as follows:

    1. The amount starts with '$'.

    2. The amount could have a leading '0' if and only if it is less then 1.

    3. The amount ends with a decimal point and exactly 2 following digits.

    4. The digits to the left of the decimal point are separated into groups of three by commas

     (a group of one or two digits may appear on the left).

    Input

    The input consists of multiple tests. The first line of each test contains an integer N

     (1 <= N <= 10000) which indicates the number of amounts. The next N lines

     contain N amounts. All amounts and the total amount are between $0.00

     and $20,000,000.00, inclusive. N=0 denotes the end of input.

    Output

    For each input test, output the total amount.

    Sample Input

    2

    $1,234,567.89

    $9,876,543.21

    3

    $0.01

    $0.10

    $1.00

    0

    Sample Output

    $11,111,111.10

    $1.11

    #include <iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    char a[30],ch[20];
    long long sum,ans;
    int i,n,l;
    int main()
    {
        while(scanf("%d",&n) && n)
        {
           ans=0;
           for(;n>0;n--)
           {
               scanf("%s",ch);
               l=strlen(ch);
               sum=0;
               for(i=1;i<l;i++)
                if(ch[i]>='0' && ch[i]<='9')
                    sum=sum*10+ch[i]-'0';
               ans+=sum;
           }
           printf("%c",ch[0]);
           a[1]=char(ans%10+48);
           ans=ans/10;
           a[2]=char(ans%10+48);
           ans=ans/10;
           a[3]='.';
           l=3;
           if (ans==0) {a[4]='0'; l=4;}
            else
            {
                int num=0;
                while(ans>0)
                {
                   if (num==3) a[++l]=',',num=0;
                   a[++l]=char(ans%10+48);
                   ans=ans/10;
                   num++;
                }
            }
           for(i=l;i>=1;i--) printf("%c",a[i]);
           printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    MySQL进阶
    对象关系_many2many
    objectstate对象三种状态
    自动在数据库中创建表
    Pytest学习之使用多个fixture
    Pytest学习之fixture作用范围(scope)
    python测试dubbo类型接口
    swagger接口注释添加,接口版本变更规则
    Pytest-skip跳过功能
    接口自动化测试介入项目管理流程
  • 原文地址:https://www.cnblogs.com/stepping/p/5685801.html
Copyright © 2011-2022 走看看