zoukankan      html  css  js  c++  java
  • hdu 2647 Reward(拓扑排序,反着来)

    Reward

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 51   Accepted Submission(s) : 21

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
    The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

    Input

    One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
    then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

    Output

    For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

    Sample Input

    2 1
    1 2
    2 2
    1 2
    2 1

    Sample Output

    1777
    -1
    #include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<vector>
    #include<queue>
    using namespace std;
    int i,n,m;
    int a[10002],cnt[10002];
    vector<int> s[10002];
    long long sum;
    bool toposort()
    {
        queue<int> Q;
        int num=0;
        for(int i=1;i<=n;i++)
            if (cnt[i]==0) {Q.push(i); a[i]=888;}
        while(!Q.empty())
        {
            int u=Q.front();
            num++;
            Q.pop();
            for(int i=0;i<s[u].size();i++)
            {
                cnt[s[u][i]]--;
                if (cnt[s[u][i]]==0)
                    {
                        Q.push(s[u][i]);
                        a[s[u][i]]=max(a[u]+1,a[s[u][i]]);
                    }
            }
        }
        if (num<n) return 0;
        return 1;
    }
    int main()
    {
    
        while(~scanf("%d%d",&n,&m))
        {
            for(i=1;i<=n;i++) s[i].clear();
            memset(cnt,0,sizeof(cnt));
            for(i=1;i<=m;i++)
            {
                int x,y;
                scanf("%d%d",&y,&x);
                s[x].push_back(y);
                cnt[y]++;
            }
            memset(a,0,sizeof(a));
            if (!toposort())
            {
                printf("-1\n");
                continue;
            }
            sum=0;
            for(i=1;i<=n;i++) sum+=a[i];
            printf("%lld\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    授权中的with admin option和with grant option
    CentOS6.2(64bit)下mysql5.6.16主从同步配置
    linux zip命令
    从模版中找到控件的方法和找到样式的方法
    WPF 在事件中绑定命令(不可以在模版中绑定命令)
    WPF: ShowDialog() 切换到其他应用窗口后,再切换回来无法让子窗口总在最上方
    TreeViewItem实现整行选中 (两种用法)
    BitmapImage 读取内存流和显示图片
    IsKeyboardFocused -- 键盘焦点
    WPF中的imagesource 和内存图片的处理
  • 原文地址:https://www.cnblogs.com/stepping/p/5700373.html
Copyright © 2011-2022 走看看