zoukankan      html  css  js  c++  java
  • USACO_Mixing Milk

    Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

    The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer's limit.

    Given the Merry Milk Makers' daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers' requirements.

    Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

    PROGRAM NAME: milk

    INPUT FORMAT

    Line 1: Two integers, N and M. 
    The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers wants per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from. 
    Lines 2 through M+1: The next M lines each contain two integers, Pi and Ai
    Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges.
    Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

    SAMPLE INPUT (file milk.in)

    100 5
    5 20
    9 40
    3 10
    8 80
    6 30
    

    OUTPUT FORMAT

    A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

    SAMPLE OUTPUT (file milk.out)

    630


    这个题目一开始没看懂,觉着很难,现在

    /*
    ID:rongkan1
    LANG: JAVA
    TASK: milk
    */
    
    import java.io.FileInputStream;
    import java.io.FileNotFoundException;
    import java.io.PrintWriter;
    import java.util.*;
    
    public class milk {
    
        /**
         * @param args
         * @throws FileNotFoundException 
         */
        public static void main(String[] args) throws FileNotFoundException {
            // TODO Auto-generated method stub
            ArrayList<Row> rows= new ArrayList<Row>();
            Scanner sin = new Scanner(new FileInputStream("milk.in"));
            PrintWriter writer = new PrintWriter("milk.out");
            int N=sin.nextInt(),M=sin.nextInt();
            
            for(int i=0;i<M;i++){
                rows.add(new Row(sin.nextInt(),sin.nextInt()));
            }
            Collections.sort(rows, new RowComp());
            int count=N;
            int total=0;
            int c;
            for(int i=0;i<rows.size();i++){
                if(count<=rows.get(i).quantity){
                    total+=rows.get(i).price*count;
                    break;
                }
                count-=rows.get(i).quantity;
                total+=rows.get(i).quantity*rows.get(i).price;
                
            }
            writer.println(total);
            writer.close();
            sin.close();
        }
    
    }
    class RowComp implements Comparator<Row>{
    
        @Override
        public int compare(Row o1, Row o2) {
            // TODO Auto-generated method stub
            if(o1.price <o2.price)return -1;
            else if(o1.price>o2.price)return 1;
            else return 0;
        }
        
    }
    class Row {
        int price;
        int quantity;
        Row(int price,int quantity){
            this.price=price;
            this.quantity=quantity;
        }
    }
  • 相关阅读:
    ASP.NET SignalR HubPipelineModule
    MongoDB新版本特性
    Xamarin向iOS和Android引入C# Async支持
    Redis开源文档《Redis设计与实现》[转]
    WCF的追踪分析工具——SvcPerf
    Windows Azure移动服务更新,支持Android、活动目录和更多语言,并支持在东亚地区部署服务
    社区网站系统 jsGen
    单元测试同时支持 NUnit/MSTest
    .NET的微型Web框架 Nancy
    通过二维码登录(CSC模式)
  • 原文地址:https://www.cnblogs.com/stonehat/p/2530951.html
Copyright © 2011-2022 走看看