zoukankan      html  css  js  c++  java
  • POJ 1804 逆序对数量 / 归并排序

    Brainman
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 12175   Accepted: 6147

    Description

    Background 
    Raymond Babbitt drives his brother Charlie mad. Recently Raymond counted 246 toothpicks spilled all over the floor in an instant just by glancing at them. And he can even count Poker cards. Charlie would love to be able to do cool things like that, too. He wants to beat his brother in a similar task. 

    Problem 
    Here's what Charlie thinks of. Imagine you get a sequence of N numbers. The goal is to move the numbers around so that at the end the sequence is ordered. The only operation allowed is to swap two adjacent numbers. Let us try an example: 
    Start with: 2 8 0 3 
    swap (2 8) 8 2 0 3 
    swap (2 0) 8 0 2 3 
    swap (2 3) 8 0 3 2 
    swap (8 0) 0 8 3 2 
    swap (8 3) 0 3 8 2 
    swap (8 2) 0 3 2 8 
    swap (3 2) 0 2 3 8 
    swap (3 8) 0 2 8 3 
    swap (8 3) 0 2 3 8

    So the sequence (2 8 0 3) can be sorted with nine swaps of adjacent numbers. However, it is even possible to sort it with three such swaps: 
    Start with: 2 8 0 3 
    swap (8 0) 2 0 8 3 
    swap (2 0) 0 2 8 3 
    swap (8 3) 0 2 3 8

    The question is: What is the minimum number of swaps of adjacent numbers to sort a given sequence?Since Charlie does not have Raymond's mental capabilities, he decides to cheat. Here is where you come into play. He asks you to write a computer program for him that answers the question. Rest assured he will pay a very good prize for it.

    Input

    The first line contains the number of scenarios. 
    For every scenario, you are given a line containing first the length N (1 <= N <= 1000) of the sequence,followed by the N elements of the sequence (each element is an integer in [-1000000, 1000000]). All numbers in this line are separated by single blanks.

    Output

    Start the output for every scenario with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the minimal number of swaps of adjacent numbers that are necessary to sort the given sequence. Terminate the output for the scenario with a blank line.

    Sample Input

    4
    4 2 8 0 3
    10 0 1 2 3 4 5 6 7 8 9
    6 -42 23 6 28 -100 65537
    5 0 0 0 0 0

    Sample Output

    Scenario #1:
    3
    
    Scenario #2:
    0
    
    Scenario #3:
    5
    
    Scenario #4:
    0
    题意 两个位置的元素可以任意交换 交换最少的数量使序列有序
    解析 归并排序求逆序对
    AC代码
    #include<iostream>
    #include<stdio.h>
    using namespace std;
    const int maxn = 1e5+50,inf=0x3f3f3f3f;
    typedef long long ll;
    const int mod=1e9+7;
    int a[maxn],t[maxn],ans;
    void merge_sort(int *a,int x,int y,int *t)
    {
        if(y-x>1)
        {
            int m=x+(y-x)/2;    //划分
            int p=x,q=m,i=x;
            merge_sort(a,x,m,t); //递归求解
            merge_sort(a,m,y,t); //递归求解
            while(p<m||q<y)    //只要有一个序列非空就要继续合并
            {
    
                if(q>=y||( p<m && a[p]<=a[q]))  //当第二个序列为空直接复制 两个都不为空进行比较
                    t[i++]=a[p++];
                else
                    t[i++]=a[q++],ans+=m-p;
            }
            for(int i=x;i<y;i++)    //将排好序的数组再复制回给a
                a[i]=t[i];
        }
    }
    int main()
    {
        int n,m,kase=1;
        cin>>m;
        while(m--)
        {
            cin>>n;
            ans=0;
            for(int i=0;i<n;i++)
            {
                cin>>a[i];
            }
            merge_sort(a,0,n,t);//左闭右开
            printf("Scenario #%d:
    %d
    
    ",kase++,ans);
        }
    }

    归并排序

    /*
    
    分治三步法:
    
        划分问题:把序列分成元素个数尽量相等的两半
        递归求解:把两半元素分别排序
        合并问题:把两个有序表合并成一个
    */
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn = 1e5+50,inf=0x3f3f3f3f;
    typedef long long ll;
    const int mod=1e9+7;
    int a[maxn],t[maxn];
    void merge_sort(int *a,int x,int y,int *t)
    {
        if(y-x>1)
        {
            int m=x+(y-x)/2;    //划分
            int p=x,q=m,i=x;
            merge_sort(a,x,m,t); //递归求解
            merge_sort(a,m,y,t); //递归求解
            while(p<m||q<y)    //只要有一个序列非空就要继续合并
            {
    
                if(q>=y||( p<m && a[p]<=a[q]))  //当第二个序列为空直接复制 两个都不为空进行比较
                    t[i++]=a[p++];
                else
                    t[i++]=a[q++];
            }
            for(int i=x;i<y;i++)    //将排好序的数组再复制回给a
                a[i]=t[i];
        }
    }
    int main()
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        merge_sort(a,0,n,t);//左闭右开
        for(int i=0;i<n;i++)
        {
            cout<<a[i]<<" ";
        }
        cout<<endl;
    }
  • 相关阅读:
    头条前端笔试最后一道题
    Node读取和写入json,格式化输出json
    CSS中的未定义行为,浏览器的差异(一)
    18.2.28阿里前端实习生内推面补坑
    18.2.26深信服Web实习生补坑(已拿到offer)
    MySQL Parameter '?…' has already been defined 是什么问题
    C# List<T>的 Find方法、FindLast方法、FindAll方法、FindIndex方法
    C# 对List<T>进行排序
    SQL里 asc和desc的意思
    Visual Studio同步的时候显示 team foundation 错误 系统找不到指定文件夹
  • 原文地址:https://www.cnblogs.com/stranger-/p/9273046.html
Copyright © 2011-2022 走看看