zoukankan      html  css  js  c++  java
  • POJ 3267 The Cow Lexicon

    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 10021   Accepted: 4814

    Description

    Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

    The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

    Input

    Line 1: Two space-separated integers, respectively: W and L 
    Line 2: L characters (followed by a newline, of course): the received message 
    Lines 3..W+2: The cows' dictionary, one word per line

    Output

    Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

    Sample Input

    6 10
    browndcodw
    cow
    milk
    white
    black
    brown
    farmer

    Sample Output

    2

    Source

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int w,l;
    char ch[610];
    string vec[610];
    int f[610];
    int main()
    {
        cin>>w>>l;
        for(int i=0;i<l;i++)
          cin>>ch[i];//  字符串
        for(int i=0;i<w;i++)
          cin>>vec[i];//  多个单词
        f[l]=0;
        for(int i=l-1;i>=0;i--)   //对于字符串 我采取 从后向前更新的 方法
        {
            f[i]=f[i+1]+1;//  最坏情况 当前字符需要删除 固由 f[i+1]+1得来
            for(int j=0;j<w;j++)//  遍历每个单词
            {
                int len=vec[j].length();//  获取单词的长度
                if(len<=l-i+1&&vec[j][0]==ch[i])  // 当前遍历到的  字符串 中的 字符到字符串尾 的长度 大于等于 当前查询的单词的长度
                {//  切当前遍历到的字符串中的字符 等于 该单词的首字母
                    int pm=i;// 字符串的指针 
                    int pz=0;//  单词的指针
                    while(pm<l)// 检索从此 向后 是否逐字匹配
                    {
                        if(vec[j][pz]==ch[pm++])
                          pz++; // 继续向后检索
                        if(pz==len)
                        {
                            f[i]=min(f[i],f[pm]+(pm-i)-len);break;// 检所完成 从i 向后到l与该单词逐字匹配  所以 更新维护f[]
                        }
                    }
                }
            }
        }
        cout<<f[0];
        
        
        return 0;
    }

    慢慢推 DP f[pm]+(pm-i)-len 这个地方是我从网上找的 至今没搞明白

  • 相关阅读:
    解决Web部署 svg/woff/woff2字体 404错误
    C# 汉字转拼音
    jquery ajax返回Internal server error 500错误解决方案
    bootstrap datepicker只能选择小于今天的日期
    向txt文件追加异常日志
    C# DataTable 和List之间相互转换的方法
    js点击行选中checkbox
    bootstrap-datepicker 插件修改为中文显示
    C# 压缩/解压字符串
    c# MD5加密
  • 原文地址:https://www.cnblogs.com/suishiguang/p/5928018.html
Copyright © 2011-2022 走看看