zoukankan      html  css  js  c++  java
  • TOJ3650 Legal or Not

    Legal or Not 分享至QQ空间 去爱问答提问或回答

    Time Limit(Common/Java):1000MS/3000MS     Memory Limit:65536KByte
    Total Submit: 41            Accepted: 18

    Description

     

    ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

    We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

    Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

     

    Input

     

    The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
    TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

     

    Output

     

    For each test case, print in one line the judgement of the messy relationship.
    If it is legal, output "YES", otherwise "NO".

     

    Sample Input

     

    3 2
    0 1
    1 2
    2 2
    0 1
    1 0
    0 0
    

     

    Sample Output

     

    YES
    NO
    

     

     

    #include <iostream>
    #include <queue>
    #include <string>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int maxn = 1000;
    
    struct info {
        int id;
        bool operator < (const info& a) const {
            return id > a.id;
        }
    };
    
     priority_queue<info> Q;
    int gn, gm;
    vector<int> g[maxn];
    int du[maxn], num = 0;
    
    void init() {
        num = 0;
        int i;
        for(i = 0; i < maxn; i++) {
            g[i].clear();
        }
        memset(du, 0, sizeof(du));
        while(!Q.empty()) Q.pop();
    }
    
    bool top_sort() {
        int i;
        info tmp;
        for(i = 0; i < gn; i++) {
            if(!du[i]) {
                tmp.id = i;
                Q.push(tmp);
            }
        }
        while(!Q.empty()) {
            info t = Q.top();
             Q.pop();
             num++;
            int x = t.id;
            for(i = 0; i < (int)g[x].size(); i++) {
                int t = g[x][i];
                du[t]--;
                if(!du[t]) {
                    tmp.id = t;
                    Q.push(tmp);
                }
            }
        }
        if(num==gn) {
            return true;
        }
        return false;
    }
    
    int main()
    {
        int i;
        int from, to;
        while(scanf("%d%d", &gn,&gm) != EOF) {
            if(gn ==0 && gm==0) break;
            init();
            for(i = 0; i < gm; i++) {
                scanf("%d%d", &from, &to);
                g[from].push_back(to);
                du[to]++;
            }
           bool res = top_sort();
           if(res) {
                cout << "YES" << endl;
           } else {
                cout << "NO" << endl;
           }
        }
    }
  • 相关阅读:
    mysql日志
    MYSQL-事务中的锁与隔离级别
    MYSQL事务的日志
    Innodb核心特性-事务
    Innodb存储引擎-表空间介绍
    innodb存储引擎简介
    MYSQL之存储引擎
    MYSQL之索引配置方法分类
    MYSQL之索引算法分类
    MYSQL之select的高级用法
  • 原文地址:https://www.cnblogs.com/suncoolcat/p/3285831.html
Copyright © 2011-2022 走看看