zoukankan      html  css  js  c++  java
  • hdu 2069 限制个数的母函数(普通型)

    Coin Change

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 17266    Accepted Submission(s): 5907


    Problem Description
    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
     

    Input
    The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
     

    Output
    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
     

    Sample Input
    
    
    11 26
     

    Sample Output
    
    
    4 13
     

    Author
    Lily
     
    题意: 能不能用1 5 10 25 50 组成输入的数,并且使用的个数不能超过100个。
     
    思路:
    多加一维维护个数。a[j][l] 表示值为j,用了l个的时候有多少种方案。
    #include<set>
    #include<map>
    #include<queue>
    #include<stack>
    #include<cmath>
    #include<string>
    #include<vector>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define INF 1000000001
    #define MOD 1000000007
    #define ll long long
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define pi acos(-1.0)
    using namespace std;
    const int MAXN = 300;
    int c[MAXN][105],tp[MAXN][105],n,val[6];
    int main()
    {
        val[1] = 1,val[2] = 5,val[3] = 10,val[4] = 25,val[5] = 50;
        while(~scanf("%d",&n)){
            if(!n){
                puts("1");
                continue;
            }
            memset(c,0,sizeof(c));
            memset(tp,0,sizeof(tp));
            for(int i = 0; i <= min(n,100); i++){
                c[i][i] = 1;
            }
            for(int i = 2; i <= 5; i++){
                for(int j = 0; j <= n; j++){
                    for(int k = 0; k + j <= n; k += val[i]){
                        for(int l = 0; l + k / val[i] <= 100; l ++){
                            tp[j + k][l + k / val[i]] += c[j][l];
                        }
                    }
                }
                for(int j = 0; j <= n; j++){
                    for(int k = 0; k <= 100; k++){
                        c[j][k] = tp[j][k];
                        tp[j][k] = 0;
                    }
                }
            }
            int ans = 0;
            for(int i = 1; i <= 100; i++){
                ans += c[n][i];
            }
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    学习笔记(4)---JQuery
    学习笔记---ES6
    angular.js的学习笔记(1)
    vue.js学习笔记(1)
    HTML5“爱心鱼”游戏总结
    学习笔记(3)---综合
    学习笔记(2)---CSS中的易混淆点
    学习笔记(1)----水平垂直居中的方法
    javascript:void(0)是什么意思
    private Int32? m_shopid;
  • 原文地址:https://www.cnblogs.com/sweat123/p/5515414.html
Copyright © 2011-2022 走看看