zoukankan      html  css  js  c++  java
  • UVA 10106 Product

    10106 - Product

     

    The Problem

    The problem is to multiply two integers X, Y. (0<=X,Y<10250)

    The Input

    The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

    The Output

    For each input pair of lines the output line should consist one integer the product.

    Sample Input

     

    12
    12
    2
    222222222222222222222222
    

     

    Sample Output

     

    144
    444444444444444444444444

    # include <stdio.h>
    # include <stdlib.h>
    # include <string.h>
    
    #define MAXN 1000
    
    int a[MAXN];
    char s1[MAXN], s2[MAXN];
    
    int main ( ){
        int i, j, p, len1, len2;
        while(scanf("%s %s", s1, s2) == 2){
            memset(a, 0, sizeof(a));
            len1 = strlen(s1); len2 = strlen(s2);
            for(i=len1-1; i>=0; i--)
                for(j=len2-1, p=len1-1-i; j>=0; j--){
                    a[p++] += (s1[i]-'0')*(s2[j]-'0');
                }
            for(i=0; i<MAXN; i++){
                a[i+1] += a[i]/10;
                a[i] %= 10;
            }
    
            for(i=MAXN-1; i>=0; i--) if(a[i]) break;
            if(i==-1) printf("0");
            else for(; i>=0; i--) printf("%d", a[i]);
            putchar('\n');
        }
    
        return 0;
    }


  • 相关阅读:
    Linux基础命令(一)
    You've made choice
    protege推理
    字符编码
    第二次作业
    数据类型-集合set
    数据类型-元组&字典
    数据类型-列表
    数据类型-数值&字符串
    流程控制之for循环
  • 原文地址:https://www.cnblogs.com/tanhehe/p/2883513.html
Copyright © 2011-2022 走看看