zoukankan      html  css  js  c++  java
  • PAT A1007 Maximum Subsequence Sum (25 分)——最大子列和,动态规划

    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4
    #include <stdio.h>
    #include <stdlib.h>
    #include <algorithm>
    using namespace std;
    const int maxn = 10010;
    int s[maxn] = { 0 };
    int res[maxn] = { 0 };
    int main(){
        int n;
        scanf("%d", &n);
        for (int i = 0; i<n; i++){
            scanf("%d", &s[i]);
        }
        res[0] = s[0];
        for (int i = 1; i<n; i++){
            res[i] = max(s[i], res[i - 1] + s[i]);
        }
        /*for (int i = 1; i < n; i++){
            if (res[i - 1] + s[i] < 0)res[i] = s[i];
            else res[i] = res[i - 1] + s[i];
        }*/
        int maxi = 0;
        for (int i = 1; i<n; i++){
            if (res[i]>res[maxi]){
                maxi = i;
            }
        }
        if (maxi == 0 && s[0]<0)printf("0 %d %d", s[0], s[n - 1]);
        else{
            printf("%d ", res[maxi]);
            int mini = maxi;
            int sum = 0;
            do{
                sum += s[mini--];
                
            } while (sum != res[maxi]);
            mini++;
            printf("%d %d", s[mini], s[maxi]);
        }
        system("pause");
    }

    注意点:又是最大子列和问题,不仅要最大子列和答案,还要输出子列的首尾数字。知道可以用动态规划做,做了半天答案一直错误,发现是动态规划想错了,不是一小于0就把值赋给自己,而是要取(自己)和(自己加上前面的最大子列和)的最大值。后面找索引时要用do...while,否则最大子列和只有自身一个数的时候会出错。

    ---------------- 坚持每天学习一点点
  • 相关阅读:
    FirstApp,iphone开发学习总结10,归档(序列化、固化)
    FirstApp,iphone开发学习总结9,旋转
    iphone开发学习,开源之UIAlertViewBlocks
    FirstApp,iphone开发学习总结13,方向感应和通告
    iphone开发学习,开源之Three20
    FirstApp,iphone开发学习总结11,表操作(移动、删除)
    FirstApp,iphone开发学习总结12,播放音乐、视频
    iphone开发学习,开源,ASIHTTPRequest的学习
    iphone开发学习,开源之SVWebViewController,UIWebView支持后退、前进、刷新、使用Safari打开
    iphone开发学习,Block
  • 原文地址:https://www.cnblogs.com/tccbj/p/10371210.html
Copyright © 2011-2022 走看看