zoukankan      html  css  js  c++  java
  • HDU1054-Strategic Game

    Strategic Game

    Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4114    Accepted Submission(s): 1824

    Problem Description
    Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?
    Your program should find the minimum number of soldiers that Bob has to put for a given tree.
    The input file contains several data sets in text format. Each data set represents a tree with the following description:
    the number of nodes the description of each node in the following format node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier or node_identifier:(0)
    The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.
    For example for the tree:

    the solution is one soldier ( at the node 1).
    The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
     
    Sample Input
    4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
     
    Sample Output
    1 2
     
    Source
     
     
    第一道树形DP,感觉就是考察树的遍历,DP还是比较简单的
     
    #include<stdio.h>
    #include<vector>
    #include<cstring>
    #define N 1505
    using namespace std;
    int dp[N][2],visit[N];
    vector<int> V[N];
    int min(int a,int b)
    {
     return a>b?b:a;
    }
    void dfs(int k)
    {
     int i;
     for(i=0;i<V[k].size();i++)
     {
      if(visit[V[k][i]] == 0)   //判断是否为子节点
      {
       visit[ V[k][i] ] = 1;
       dfs(V[k][i]);
       visit[ V[k][i] ] = 0;
      }
     }
     int s1=0,s2=0;
     for(i=0;i<V[k].size();i++)
     {
      if(visit[V[k][i]] == 0)   //判断是否为子节点
      {
       s1 += min(dp[ V[k][i] ][0] , dp[V[k][i]][1]);
       s2 += dp[ V[k][i] ][1];
      }
     }
     dp[k][1] = s1+1;
     dp[k][0] = s2;
    }
    int main()
    {
     int n,i,j,t;
     char a[20];
     while(scanf("%d",&n)!=EOF)
     {
      memset(visit,0,sizeof(visit));
      visit[1]=1;
      for(i=0;i<n;i++)
       V[i].clear();
      for(i=0;i<n;i++)
      {
       scanf("%s",a);
       int len=strlen(a);
       int cc=0,tt=0;
       j=0;
       while(a[j]!='(')
       {
        if(a[j]>='0' && a[j]<='9')
         cc=cc*10+a[j]-'0';
        j++;
       }
       while(a[j]!=')')
       {
        if(a[j]>='0' && a[j]<='9')
         tt=tt*10+a[j]-'0';
        j++;
       }
       for(j=0;j<tt;j++)
       {
        scanf("%d",&t);
        V[cc].push_back(t);
        V[t].push_back(cc);
       }
      }
      memset(dp,0,sizeof(dp));
      dfs(1);
      printf("%d ",min(dp[1][0] , dp[1][1]));
     }
     return 0;
    }
  • 相关阅读:
    老杆子遇到新问题
    Linux 下网路适配器配置
    OpenCV学习笔记2_ShowAvi_获取Avi视频图像、摄像头图像
    OpenCV学习笔记3_ShowAvi_Trackbar_加载视频,并添加拖动条
    PS照片
    OpenCV学习笔记7_ImageToBGR_彩色图像三通道转化成BGR3幅单通道图像
    #include "stdafx.h"_预编译头文件
    OpenCV学习笔记1_ShowImage_显示一幅图像
    Visual Assist X_VS2010编程插件安装
    OpenCV学习笔记4_ImageToAvi_写视频
  • 原文地址:https://www.cnblogs.com/tengtao93/p/3462869.html
Copyright © 2011-2022 走看看