zoukankan      html  css  js  c++  java
  • 洛谷P1879 [USACO06NOV]玉米田Corn Fields

    P1879 [USACO06NOV]玉米田Corn Fields

    题目描述

    Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

    Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

    农场主John新买了一块长方形的新牧场,这块牧场被划分成M行N列(1 ≤ M ≤ 12; 1 ≤ N ≤ 12),每一格都是一块正方形的土地。John打算在牧场上的某几格里种上美味的草,供他的奶牛们享用。

    遗憾的是,有些土地相当贫瘠,不能用来种草。并且,奶牛们喜欢独占一块草地的感觉,于是John不会选择两块相邻的土地,也就是说,没有哪两块草地有公共边。

    John想知道,如果不考虑草地的总块数,那么,一共有多少种种植方案可供他选择?(当然,把新牧场完全荒废也是一种方案)

    输入输出格式

    输入格式:

    第一行:两个整数M和N,用空格隔开。

    第2到第M+1行:每行包含N个用空格隔开的整数,描述了每块土地的状态。第i+1行描述了第i行的土地,所有整数均为0或1,是1的话,表示这块土地足够肥沃,0则表示这块土地不适合种草。

    输出格式:

    一个整数,即牧场分配总方案数除以100,000,000的余数。

    输入输出样例

    输入样例#1:
    2 3
    1 1 1
    0 1 0
    输出样例#1:
    9
    /*
        数据范围12,加上01矩阵,状丫dp就基本确定了 
        预处理出每一行的所有状态,然后dp就枚举状态,加法原理 
        sta[i][j]第i行的第j个状态是什么 
        sta_num[i]第i行一共有几个状态 
        dp[i][j]计算到第i行,且这一行状态为j的方案数
        答案就为最后一行所有状态对应方案数的和 
    */
    #include<iostream>
    #include<cstdio>
    using namespace std;
    #define mod 100000000
    int n,m,map[13][13],sta[13][1<<12],sta_num[13],dp[13][1<<12];
    bool check(int line,int now){
        for(int i=1;i<=m;i++)
            if((now&(1<<(i-1)))&&!map[line][i])return false;
        for(int i=1;i<m;i++)
            if((now&(1<<(i-1)))&&(now&(1<<i)))return false;
        return true;
    }
    int main(){
        //freopen("Cola.txt","r",stdin);
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&map[i][j]);
        for(int i=1;i<=n;i++)
            for(int j=0;j<(1<<m);j++)
                if(check(i,j))
                    sta[i][++sta_num[i]]=j;
        for(int i=1;i<=sta_num[1];i++)dp[1][sta[1][i]]=1;
        for(int i=2;i<=n;i++){//枚举每一行 
            for(int j=1;j<=sta_num[i];j++){//枚举这一行的每个状态 
                int sta_now=sta[i][j];
                for(int k=1;k<=sta_num[i-1];k++){//枚举上一行的每个状态 
                    int sta_pre=sta[i-1][k];
                    if(sta_now&sta_pre)continue;
                    else dp[i][sta_now]=(dp[i][sta_now]+dp[i-1][sta_pre])%mod;
                }
            }
        }
        int ans=0;
        for(int i=1;i<=sta_num[n];i++)
            ans=(ans+dp[n][sta[n][i]])%mod;
        printf("%d",ans);
    }
  • 相关阅读:
    获取华为OID
    win10 mongodb的安装
    第一次使用plotly画图遇到的问题
    Java Serialable序列化
    yield(),sleep(),join()
    线程的启动的两种方法,Runnable接口,run()的调用
    Thread的中断机制
    Oracle VM VirtualBox 修改备份位置
    潜在因子算法
    Linux--常用命令
  • 原文地址:https://www.cnblogs.com/thmyl/p/7400743.html
Copyright © 2011-2022 走看看