zoukankan      html  css  js  c++  java
  • 洛谷P2915 [USACO08NOV]奶牛混合起来Mixed Up Cows

    P2915 [USACO08NOV]奶牛混合起来Mixed Up Cows

    题目描述

    Each of Farmer John's N (4 <= N <= 16) cows has a unique serial number S_i (1 <= S_i <= 25,000). The cows are so proud of it that each one now wears her number in a gangsta manner engraved in large letters on a gold plate hung around her ample bovine neck.

    Gangsta cows are rebellious and line up to be milked in an order called 'Mixed Up'. A cow order is 'Mixed Up' if the sequence of serial numbers formed by their milking line is such that the serial numbers of every pair of consecutive cows in line differs by more than K (1 <= K <= 3400). For example, if N = 6 and K = 1 then 1, 3, 5, 2, 6, 4 is a 'Mixed Up' lineup but 1, 3, 6, 5, 2, 4 is not (since the consecutive numbers 5 and 6 differ by 1).

    How many different ways can N cows be Mixed Up?

    For your first 10 submissions, you will be provided with the results of running your program on a part of the actual test data.

    POINTS: 200

    约翰家有N头奶牛,第i头奶牛的编号是Si,每头奶牛的编号都是唯一的。这些奶牛最近 在闹脾气,为表达不满的情绪,她们在挤奶的时候一定要排成混乱的队伍。在一只混乱的队 伍中,相邻奶牛的编号之差均超过K。比如当K = 1时,1, 3, 5, 2, 6, 4就是一支混乱的队伍, 而1, 3, 6, 5, 2, 4不是,因为6和5只差1。请数一数,有多少种队形是混乱的呢?

    输入输出格式

    输入格式:
    • Line 1: Two space-separated integers: N and K

    • Lines 2..N+1: Line i+1 contains a single integer that is the serial number of cow i: S_i
    输出格式:
    • Line 1: A single integer that is the number of ways that N cows can be 'Mixed Up'. The answer is guaranteed to fit in a 64 bit integer.

    输入输出样例

    输入样例#1:
    4 1 
    3 
    4 
    2 
    1 
    
    输出样例#1:
    2 
    

    说明

    The 2 possible Mixed Up arrangements are:

    3 1 4 2

    2 4 1 3

    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstdlib>
    #define maxn 20
    using namespace std;
    int n,k,a[maxn],ans;
    bool vis[maxn];
    void dfs(int cnt,int pre){
        if(cnt==n){ans++;return;}
        for(int i=1;i<=n;i++){
            if(!vis[i]&&abs(a[i]-pre)>k){
                vis[i]=1;
                dfs(cnt+1,a[i]);
                vis[i]=0;
            }
        }
    }
    int main(){
        freopen("Cola.txt","r",stdin);
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        dfs(0,-4000);
        printf("%d",ans);
    }
    70分 暴力
    /*
        记忆化搜索,f[sta][i]表示选了的牛的集合为sta,且最后一个牛是i的混乱序列方案数 
    */
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #include<cstdlib>
    #define maxn 20
    #ifdef WIM32
    #define LL "%I64d"
    #else
    #define LL "%lld"
    #endif
    using namespace std;
    int n,k,a[maxn],ans;
    bool vis[maxn];
    long long f[1<<16][20];
    long long dfs(int sta,int cnt,int pre){
        if(cnt==n){return f[sta][pre]=1;}
        if(f[sta][pre]!=-1)return f[sta][pre];
        long long res=0;
        for(int i=1;i<=n;i++){
            if(!vis[i]&&abs(a[i]-a[pre])>k){
                vis[i]=1;
                res+=dfs(sta+(1<<(i-1)),cnt+1,i);
                vis[i]=0;
            }
        }
        f[sta][pre]=res;
        return res;
    }
    int main(){
        memset(f,-1,sizeof(f));
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        a[0]=-4000;
        dfs(0,0,0);
        printf(LL,f[0][0]);
    }
    100分 记忆化搜索
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstdlib>
    #ifdef WIN32
    #define LL "%I64d"
    #else 
    #define LL "%lld"
    #endif
    using namespace std;
    int n,k,a[20];
    long long f[1<<16][20];
    int main(){
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)f[(1<<(i-1))][i]=1;
        for(int sta=2;sta<(1<<n);sta++){
            for(int i=1;i<=n;i++){
                if(sta&(1<<(i-1))){
                    for(int j=1;j<=n;j++){
                        if(abs(a[j]-a[i])>k)f[sta][i]+=f[sta^(1<<(i-1))][j];
                    }
                }
            }
        }
        long long ans=0;
        for(int i=1;i<=n;i++)ans+=f[(1<<n)-1][i];
        printf(LL,ans);
    }
    100分 递推
  • 相关阅读:
    Linux 目录结构
    date命令--修改linux系统时间
    uniq linux下去除重复行命令
    Linux查看程序端口占用情况
    openfire连接登陆优化方案
    hdu 4848 搜索+剪枝 2014西安邀请赛
    经常使用ARM汇编指令
    一维DFT
    C++ lambda 表达式传递的变量默认不可变
    wm命令用法及LCD显示图标大小不正常时解决的方法
  • 原文地址:https://www.cnblogs.com/thmyl/p/7647495.html
Copyright © 2011-2022 走看看