zoukankan      html  css  js  c++  java
  • 洛谷P3043 [USACO12JAN]牛联盟Bovine Alliance

    P3043 [USACO12JAN]牛联盟Bovine Alliance

    题目描述

    Bessie and her bovine pals from nearby farms have finally decided that they are going to start connecting their farms together by trails in an effort to form an alliance against the farmers. The cows in each of the N (1 <= N <= 100,000) farms were initially instructed to build a trail to exactly one other farm, for a total of N trails. However months into the project only M (1 <= M < N) of these trails had actually been built.

    Arguments between the farms over which farms already built a trail now threaten to split apart the cow alliance. To ease tension, Bessie wishes to calculate how many ways the M trails that exist so far could have been built. For example, if there is a trail connecting farms 3 and 4, then one possibility is that farm 3 built the trail, and the other possibility is that farm 4 built the trail. Help Bessie by calculating the number of different assignments of trails to the farms that built them, modulo 1,000,000,007. Two assignments are considered different if there is at least one trail built by a different farm in each assignment.

    给出n个点m条边的图,现把点和边分组,每条边只能和相邻两点之一分在一组,点可以单独一组,问分组方案数。

    输入输出格式

    输入格式:
    • Line 1: Two space-separated integers N and M

    • Lines 2..1+M: Line i+1 describes the ith trail. Each line contains two space-separated integers u_i and v_i (1 <= u_i, v_i <= N, u_i != v_i) describing the pair of farms connected by the trail.
    输出格式:
    • Line 1: A single line containing the number of assignments of trails to farms, taken modulo 1,000,000,007. If no assignment satisfies the above conditions output 0.

    输入输出样例

    输入样例#1: 复制
    5 4 
    1 2 
    3 2 
    4 5 
    4 5 
    
    输出样例#1: 复制
    6 
    

    说明

    Note that there can be two trails between the same pair of farms.

    There are 6 possible assignments. Letting {a,b,c,d} mean that farm 1 builds trail a, farm 2 builds trail b, farm 3 builds trail c, and farm 4 builds trail d, the assignments are:

    {2, 3, 4, 5} 
    {2, 3, 5, 4} 
    {1, 3, 4, 5} 
    {1, 3, 5, 4} 
    {1, 2, 4, 5} 
    {1, 2, 5, 4} 
    #include<iostream>
    #include<cstdio>
    #include<queue>
    #include<cstdlib>
    #define maxn 100010
    #define mod 1000000007
    using namespace std;
    int n,m,num,head[maxn];
    long long ans=1;
    bool vis[maxn];
    struct node{
        int to,pre;
    }e[maxn*2];
    void Insert(int from,int to){
        e[++num].to=to;
        e[num].pre=head[from];
        head[from]=num;
    }
    void bfs(int s){
        queue<int>q;
        q.push(s);vis[s]=1;
        int cnt1=1,cnt2=0;
        while(!q.empty()){
            int now=q.front();q.pop();
            for(int i=head[now];i;i=e[i].pre){
                int to=e[i].to;
                cnt2++;
                if(!vis[to]){
                    vis[to]=1;
                    cnt1++;
                    q.push(to);
                }
            }
        }
        cnt2/=2;
        if(cnt1==cnt2)ans=(2LL*ans)%mod;
        else if(cnt1-1==cnt2)ans=(1LL*cnt1*ans)%mod;
        else {puts("0");exit(0);}
    }
    int main(){
        scanf("%d%d",&n,&m);
        int x,y;
        for(int i=1;i<=m;i++){
            scanf("%d%d",&x,&y);
            Insert(x,y);Insert(y,x);
        }
        for(int i=1;i<=n;i++){
            if(!vis[i])bfs(i);
        }
        cout<<ans;
    }
     
  • 相关阅读:
    poj 1273 Drainage Ditches
    网络流之--混合图的欧拉回路 出自yzmduncan.iteye.com/blog/1149049
    hdu 2203 亲和串 kmp
    hdu 1711 kmp
    KMP算法详解 出自matrix67.com
    zoj 2016 Play on Words 欧拉回路
    修改document.domain的注意事项(转)
    ActiveXObject函数详解(转)
    angularjs
    sbt
  • 原文地址:https://www.cnblogs.com/thmyl/p/7811045.html
Copyright © 2011-2022 走看看