zoukankan      html  css  js  c++  java
  • UVALive3135 UVA1203 POJ2051 ZOJ2212 Argus【优先队列】

    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 11450   Accepted: 5545

    Description

    A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
    Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
    Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

    We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 

    For the Argus, we use the following instruction to register a query: 
    Register Q_num Period

    Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 

    Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

    Input

    The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

    The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

    Output

    You should output the Q_num of the first K queries to return the results, one number per line.

    Sample Input

    Register 2004 200
    Register 2005 300
    #
    5
    

    Sample Output

    2004
    2005
    2004
    2004
    2005
    

    Source


    Regionals 2004 >> Asia - Beijing


    问题链接UVALive3135 UVA1203 POJ2051 ZOJ2212 Argus

    问题简述每个用户注册一个ID号,并且有一个间隔时间。对于每个用户,每隔一个间隔时间打印一次。注册的用户到“#”为止。之后给出k,是需要打印的用户ID数量。

    问题分析用优先队列来解决是最合适的。

    程序说明:(略)

    题记:(略)

    参考链接:(略)


    AC的C++语言程序如下:

    /* UVALive3135 UVA1203 POJ2051 ZOJ2212 Argus */
    
    #include <iostream>
    #include <queue>
    
    using namespace std;
    
    struct _node {
        int num, period, cnt;
        bool operator <(_node a)const
        {
            if(cnt != a.cnt)
                return cnt > a.cnt;
            else
                return num > a.num;
        }
    };
    
    int main()
    {
        priority_queue<_node> q;
        _node t;
        string s;
        int k;
    
        while(cin >> s) {
            if(s == "#")
                break;
            else {
                cin >> t.num >> t.period;
                t.cnt = t.period;
                q.push(t);
            }
        }
    
        cin >> k;
        while(k--) {
            t = q.top();
            q.pop();
    
            cout << t.num << endl;
    
            t.cnt += t.period;
            q.push(t);
        }
    
        return 0;
    }




  • 相关阅读:
    SpringMVC中@Controller和@RequestMapping用法和其他常用注解
    eclipse maven install 时控制台乱码问题解决
    使用模板实现编译期间多态(类名当参数)
    QT中Dialog的使用(使用QStackedWidget维护页面切换)
    QT中的各种对话框
    Qt 5 最小构建笔记(只编译QtBase)
    忽然懂了:“视图”的用途不仅仅是临时表,更适用于变化比较大的情况,而且不用改客户端一行代码
    React-Native
    一位OWin服务器新成员TinyFox
    Access Toke调用受保护的API
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563574.html
Copyright © 2011-2022 走看看