zoukankan      html  css  js  c++  java
  • HDU1075 What Are You Talking About【MAP】

    What Are You Talking About

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
    Total Submission(s): 23904    Accepted Submission(s): 8003

    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab(' '), enter(' ') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
    Output
    In this problem, you have to output the translation of the history book.
    Sample Input
    START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
    Sample Output
    hello, i'm from mars. i like earth!
    Hint
    Huge input, scanf is recommended.
    Author
    Ignatius.L

    问题链接HDU1075 What Are You Talking About

    问题简述参见上述链接。

    问题分析对于第一个BEGIN和END之间的单词对,建立一个字典。对于第二个BEGIN和END之间的行,则逐个单词查字典进行变换。

    程序说明:使用map变量存放字典。

    题记:(略)

    参考链接:(略)


    AC的C++语言程序如下:

    /* HDU1075 What Are You Talking About */
    
    #include <iostream>
    #include <map>
    #include <stdio.h>
    #include <ctype.h>
    #include <string.h>
    
    using namespace std;
    
    const int N = 10;
    char buf[N+1];
    
    int main()
    {
        string s1, s2;
        map<string, string> m;
        char c;
    
        cin >> s1;
        while(cin >> s1 >> s2) {
            if(s1 == "END")
                break;
    
            m[s2] = s1;
        }
        getchar();
    
        int i = 0;
        while(scanf("%c", &c)) {
            if(isalpha(c))
                buf[i++] = c;
            else{
                buf[i] = '';
                if(strcmp(buf, "END") == 0)
                    break;
                if(m.find(buf) != m.end()) {
                    printf("%s", m[buf].c_str());
                } else
                    printf("%s", buf);
                putchar(c);
    
                i = 0;
            }
        }
    
        return 0;
    }



  • 相关阅读:
    深刻剖析spring三种注入方式以及使用注解的原理
    springcloud(一):大话Spring Cloud
    springcloud学习资料汇总
    springboot(一):入门篇
    springboot学习资料汇总
    jvm系列(七):如何优化Java GC「译」
    jvm系列(六):Java服务GC参数调优案例
    jvm系列(五):Java GC 分析
    jvm系列(四):jvm调优-命令篇
    android view、viewgroup 事件响应拦截处理机制
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563577.html
Copyright © 2011-2022 走看看