zoukankan      html  css  js  c++  java
  • POJ1731 Orders【全排列+字符串排序】

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 10868   Accepted: 6517

    Description

    The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking. 

    You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day. 

    Input

    Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn't exceed 200. 

    Output

    Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes. 

    Sample Input

    bbjd
    

    Sample Output

    bbdj
    bbjd
    bdbj
    bdjb
    bjbd
    bjdb
    dbbj
    dbjb
    djbb
    jbbd
    jbdb
    jdbb
    

    Source


    问题链接POJ1731 Orders

    问题简述对于输入的字符串,按字典顺输出其全排列的字符串。

    问题分析:(略)

    程序说明:(略)

    题记:(略)

    AC的C++语言程序如下:

    /* POJ1731 Orders */
    
    #include <iostream>
    #include <algorithm>
    
    using namespace std;
    
    int main()
    {
        string s;
    
        while(cin >> s) {
            sort(s.begin(), s.end());
    
            do {
                cout << s << endl;
            } while(next_permutation(s.begin(), s.end()));
        }
    
        return 0;
    }



  • 相关阅读:
    新的思考方式
    我在干售后!
    设计制造嵌入式系统
    镶嵌在系统中的系统
    苏黄永郦的第六周读书报告
    苏黄永郦的第五周读书报告
    苏黄永郦的第四周读书报告
    苏黄永郦的第三周读书报告
    1051 最大子矩阵和
    1065 最小正子段和
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563615.html
Copyright © 2011-2022 走看看