zoukankan      html  css  js  c++  java
  • UVALive2288 POJ1050 HDU1081 ZOJ1074 To The Max【最大子段和+DP】

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 48948   Accepted: 25895

    Description

    Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
    As an example, the maximal sub-rectangle of the array: 

    0 -2 -7 0 
    9 2 -6 2 
    -4 1 -4 1 
    -1 8 0 -2 
    is in the lower left corner: 

    9 2 
    -4 1 
    -1 8 
    and has a sum of 15. 

    Input

    The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

    Output

    Output the sum of the maximal sub-rectangle.

    Sample Input

    4
    0 -2 -7 0 9 2 -6 2
    -4 1 -4  1 -1
    
    8  0 -2

    Sample Output

    15

    Source



    Regionals 2001 >> North America - Greater NY


    问题链接UVALive2288 POJ1050 HDU1081 ZOJ1074 To The Max

    问题简述:参见上文

    问题分析

    这是一个计算最大子矩阵和的问题。

    可以将该问题转化为计算最大子段和问题,是一个经典的动态规划问题。

    在行上,采用穷尽搜索的方法来解决。

    在列上,通过计算最大子段和来达到计算最大子矩阵的目的。

    程序说明数组b[]用于计算各行之和,其起始行从0到n-1(穷举法),实际的计算过程是动态的。

    参考链接HDU1003 Max Sum【最大子段和+DP】

    题记(略)


    AC的C++语言程序如下:

    /* UVALive2288 POJ1050 HDU1081 ZOJ1074 To The Max */
    
    #include <iostream>
    #include <limits.h>
    #include <string.h>
    
    using namespace std;
    
    const int N = 100;
    int a[N][N], b[N];
    
    int main()
    {
        int n, maxval;
    
        while(cin >> n) {
            for(int i=0; i<n; i++)
                for(int j=0; j<n; j++)
                    cin >> a[i][j];
    
            maxval = INT_MIN;
            for(int i=0; i<n; i++) {
                memset(b, 0, sizeof(b));
    
                for(int j=i; j<n; j++) {
                    int sum = 0;
                    for(int k=0; k<n; k++) {
                        b[k] += a[j][k];
    
                        if(sum + b[k] > 0)
                            sum += b[k];
                        else
                            sum = b[k];
    
                        maxval = max(maxval, sum);
                    }
                }
            }
    
            cout << maxval << endl;
        }
    
        return 0;
    }







  • 相关阅读:
    提单管理
    SAP Using Text Modules in Adobe Forms
    创建设备任务清单
    HR常用事务代码
    SAP 如何查看用户登录信息
    abap常用函数
    CK13物料价格评估的数据ALV显示
    常用事务代码
    计算物料制造成本估算,比较重要的表
    IT_sort用法实例
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563690.html
Copyright © 2011-2022 走看看