zoukankan      html  css  js  c++  java
  • POJ1028 Web Navigation【堆栈+模拟】

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 34314   Accepted: 15322

    Description

    Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this. 
    The following commands need to be supported: 
    BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 
    FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 
    VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 
    QUIT: Quit the browser. 
    Assume that the browser initially loads the web page at the URL http://www.acm.org/

    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

    Sample Input

    VISIT http://acm.ashland.edu/
    VISIT http://acm.baylor.edu/acmicpc/
    BACK
    BACK
    BACK
    FORWARD
    VISIT http://www.ibm.com/
    BACK
    BACK
    FORWARD
    FORWARD
    FORWARD
    QUIT

    Sample Output

    http://acm.ashland.edu/
    http://acm.baylor.edu/acmicpc/
    http://acm.ashland.edu/
    http://www.acm.org/
    Ignored
    http://acm.ashland.edu/
    http://www.ibm.com/
    http://acm.ashland.edu/
    http://www.acm.org/
    http://acm.ashland.edu/
    http://www.ibm.com/
    Ignored

    Source



    问题链接POJ1028 Web Navigation

    题意简述:(略)

    问题分析这个题的原题应该是UVALive2356,只是输入格式略有不同。这个是有关浏览器操作的问题,直接模拟。

    程序说明:需要使用两个堆栈存储访问履历,以备操作使用。使用堆栈是因为操作过程与堆栈是相似的。

    参考链接UVALive2356 ZOJ1061 Web Navigation【堆栈+模拟】


    AC的C++语言程序如下:

    /* POJ1028 Web Navigation */
    
    #include <iostream>
    #include <string>
    #include <stack>
    
    using namespace std;
    
    int main()
    {
        stack<string> ss, st;
        string cmd, url;
    
        ss.push("http://www.acm.org/");
    
        while(cin >> cmd) {
            if(cmd[0] == 'Q')           // QUIT
                break;
            else if(cmd[0] == 'V') {     // VISIT
                cin >> url;
                ss.push(url);
                cout << url << endl;
    
                // 清空:一旦输入一个新的URL,就不能再做FORWARD了
                while(!st.empty())
                    st.pop();
            } else if(cmd[0] == 'B') {  // BACK
                if(ss.size() > 1) {
                    st.push(ss.top());
                    ss.pop();
                    cout << ss.top() << endl;
                } else
                    cout << "Ignored" << endl;
            } else if(cmd[0] == 'F') {  // FORWARD
                if(!st.empty()) {
                    ss.push(st.top());
                    cout << st.top() << endl;
                    st.pop();
                } else
                    cout << "Ignored" << endl;
            }
        }
    
        return 0;
    }




  • 相关阅读:
    CABasicAnimation 使用
    CABasicAnimation(CAKeyframeAnimation)keypath 取值
    c++的应用领域
    QT 状态机详解 statemachine (转)
    C++默认实参
    String隐式共享
    可重入函数与不可重入函数
    堆和栈的区别(转过无数次的文章)
    Qt Model/View(转)
    C++虚函数和纯虚函数
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563698.html
Copyright © 2011-2022 走看看