zoukankan      html  css  js  c++  java
  • UVALive5369 UVa732 HDU1515 ZOJ1004 Anagrams by Stack【DFS+堆栈】

    Anagrams by Stack

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

    [
    i i i i o o o o
    i o i i o o i o
    ]
    

    where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

    Input

    The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

    Output

    For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

    [
    ]
    
    and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

    Process

    A stack is a data storage and retrieval structure permitting two operations:

    Push - to insert an item and
    Pop - to retrieve the most recently pushed item

    We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

    i i o i o o is valid, but
    i i o is not (it's too short), neither is
    i i o o o i (there's an illegal pop of an empty stack)

    Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

    Sample Input

    madam
    adamm
    bahama
    bahama
    long
    short
    eric
    rice
    

    Sample Output

    [
    i i i i o o o i o o 
    i i i i o o o o i o 
    i i o i o i o i o o 
    i i o i o i o o i o 
    ]
    [
    i o i i i o o i i o o o 
    i o i i i o o o i o i o 
    i o i o i o i i i o o o 
    i o i o i o i o i o i o 
    ]
    [
    ]
    [
    i i o i o i o o 
    ]
    

    Source: Zhejiang University Local Contest 2001


    Regionals 1991 >> North America - East Central NA


    问题链接UVALive5369 UVa732 HDU1515 ZOJ1004 Anagrams by Stack

    题意简述

    经过一系列的堆栈操作,实现回文的构词。

    通过入栈和出栈操作,实现将单词逆转,例如将TROT转换为TORT,有以下两种方法:

    [

    iiiioooo

    ioiiooio

    ]

    问题分析用堆栈进行模拟,用DFS进行搜索。实际上DFS是做的是穷尽搜索。

    程序说明:(略)


    AC的C++语言程序如下(HDU和ZOJ):

    /* HDU1515 ZOJ1004 Anagrams by Stack */
    
    #include <iostream>
    #include <string>
    #include <stack>
    #include <vector>
    
    using namespace std;
    
    string ss, st;
    stack<char> s;
    vector<char> op;
    int sslen, stlen;
    
    void dfs(int ipush, int ipop)
    {
        if(ipush == sslen && ipop == sslen)  {
            for(int i = 0; i < (int)op.size(); i ++)
                cout << op[i] << " ";
            cout << endl;
        } else {
            if(ipush + 1 <= sslen)
            {
                s.push(ss[ipush]);
                op.push_back('i');
                dfs(ipush + 1, ipop);
                s.pop();
                op.pop_back();
            }
            if(ipop + 1 <= ipush && ipop + 1 <= sslen && s.top() == st[ipop])
            {
                char tc = s.top();
                s.pop();
                op.push_back('o');
                dfs(ipush, ipop + 1);
                s.push(tc);
                op.pop_back();
            }
        }
    }
    
    int main()
    {
        while(cin >> ss >> st) {
            sslen = ss.length();
            stlen = st.length();
    
            cout << "[" << endl;
            if(sslen == stlen)
                dfs(0, 0);
            cout << "]" << endl;
    
            while(!s.empty())
                s.pop();
            op.clear();
        }
    
        return 0;
    }


    AC的C++语言程序如下(UVALive和UVa,格式不同,每行后没有空格):

    /* UVALive5369 UVa732 Anagrams by Stack */
    
    #include <iostream>
    #include <string>
    #include <stack>
    #include <vector>
    
    using namespace std;
    
    string ss, st;
    stack<char> s;
    vector<char> op;
    int sslen, stlen;
    
    void dfs(int ipush, int ipop)
    {
        if(ipush == sslen && ipop == sslen)  {
            for(int i = 0; i < (int)op.size(); i ++) {
                if(i != 0)
                    cout << " ";
                cout << op[i];
            }
            cout << endl;
        } else {
            if(ipush + 1 <= sslen)
            {
                s.push(ss[ipush]);
                op.push_back('i');
                dfs(ipush + 1, ipop);
                s.pop();
                op.pop_back();
            }
            if(ipop + 1 <= ipush && ipop + 1 <= sslen && s.top() == st[ipop])
            {
                char tc = s.top();
                s.pop();
                op.push_back('o');
                dfs(ipush, ipop + 1);
                s.push(tc);
                op.pop_back();
            }
        }
    }
    
    int main()
    {
        while(cin >> ss >> st) {
            sslen = ss.length();
            stlen = st.length();
    
            cout << "[" << endl;
            if(sslen == stlen)
                dfs(0, 0);
            cout << "]" << endl;
    
            while(!s.empty())
                s.pop();
            op.clear();
        }
    
        return 0;
    }



  • 相关阅读:
    成熟到优秀的瓶颈问题
    今天我们为什么不成功
    将HTML标签变为小写
    2010世界杯 排阵型 猜比分
    又一款 jQuery 头图切换形式
    整理下工作环境的相应资源
    prototype 的ajax
    即时点选的菜单
    如何禁止一个输入框输入
    基于jQuery的仿FLASH 菜单
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563700.html
Copyright © 2011-2022 走看看