zoukankan      html  css  js  c++  java
  • UVA129 HDU1627 Krypton Factor

    Krypton Factor

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Total Submission(s): 392    Accepted Submission(s): 174
    Problem Description
    You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy''. Other sequences will be called ``hard''. 

    For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are: 

    BB
    ABCDACABCAB
    ABCDABCD 

    Some examples of hard sequences are: 

    D
    DC
    ABDAB
    CBABCBA
    Input
    In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences. 

    For example, with L = 3, the first 7 hard sequences are: 

    A 
    AB 
    ABA 
    ABAC 
    ABACA 
    ABACAB 
    ABACABA 
    As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group. 

    Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be 


    ABAC ABA
    7
    Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.
    Sample Input
    30 3 0 0
    Sample Output
    ABAC ABCA CBAB CABA CABC ACBA CABA 28
    Source

    问题链接UVA129 HDU1627 Krypton Factor

    问题简述:题目是因子。输入正整数n和L,输出由前L个字符组成的、字典顺序第n小的不含相邻重复字串的字符串。不含相邻重复字串的字符串是指,一个字符串中,任意两个相邻的字串都不相等。输出结果时,对于找到的字符串,每4个字符间加入一个空格,每行输出80个字符。

    问题分析:回溯法实现。从第1个字符开始试探,每个字符从"A"开始可以是L个字符之一,直到遇见第n个满足条件的字符串。试探过程中,当前的串是不包含相邻相同子串的,所以只需要考虑加入一个字符之后,是否变为包含相邻相同子串。

    程序说明:函数check()用于检查一个串是否有相邻的相等的子串,如果没有则返回true,否则返回false。


    AC的C++语言程序如下:

    /* UVA129 HDU1627 Krypton Factor */
    
    #include <iostream>
    
    using namespace std;
    
    const int MAXN = 80;
    
    int n, l, count;
    char v[MAXN+1];
    
    // 判定是否有相邻的重复子串:只需要考虑追加1个字符后是否产生相邻重复子串
    bool check(int curr)
    {
        for(int i=1; i<=(curr + 1) / 2; i++) {
            bool equal = true;
            for(int j=0; j<i; j++)
                if(v[curr - i - j] != v[curr - j]) {
                    equal = false;
                    break;
                }
            if(equal)
                return false;
        }
    
        return true;
    }
    
    void output_result(int curr)
    {
        for(int i=0; i<=curr; i++) {
            if(i % 4 == 0 && i > 0) {
                if(i % 64 == 0 && i > 0)
                    putchar('
    ');
                else
                    putchar(' ');
            }
            putchar(v[i]);
        }
        printf("
    %d
    ", curr+1);
    }
    
    // 对于第curr字符,从‘A’到第l个字母都试探一遍
    int dfs(int curr)
    {
        for(int i=0; i<l; i++) {
            v[curr] = 'A' + i;
            if(check(curr)) {
                if(++count == n) {
                    v[curr + 1] = '';
                    output_result(curr);
                    return 1;
                } else if(dfs(curr + 1))
                    return 1;
            }
        }
    
        return 0;
    }
    
    int main()
    {
        while(cin >> n >> l) {
            if(n == 0 && l == 0)
                break;
    
            count = 0;
            dfs(0);
        }
    
        return 0;
    }




  • 相关阅读:
    Oracle 基础系列之1.3 用户管理
    Oracle 系统常用命令
    Gogs安装
    centos7 Minimal安装没有ifconfig
    centos 上安装nodejs v8.0.0
    Linux 学习笔记
    使用 weinre 远程调试移动端页面
    Linux tree命令
    innodb分区
    Innodb表空间
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7564355.html
Copyright © 2011-2022 走看看