zoukankan      html  css  js  c++  java
  • sicily 1010 Zipper DP

    #include<iostream>
    #include<string>
    using namespace std;
    bool flag;
    string s1,s2,s;
    
    void dp(int len1,int len2,int len)
    {
        if(flag)    return;
        if(len==-1)        {flag=1;return;}
        if((len1>=0) && (s1[len1]==s[len]))
            dp(len1-1,len2,len-1);
        if((len2>=0) && (s2[len2]==s[len]))
            dp(len1,len2-1,len-1);
        return;
    }
    
    int main()
    {
        int num;
        cin>>num;
        for(int i=1;i<=num;i++)
        {
            flag=0;
            cin>>s1>>s2>>s;
            dp(s1.size()-1,s2.size()-1,s.size()-1);
            if(flag)
                cout<<"Data set "<<i<<": yes"<<endl;
            else    
                cout<<"Data set "<<i<<": no"<<endl;
        }
        return 0;
    }

    1010. Zipper

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB

    Description

    Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. For example, consider forming "tcraete" from "cat" and "tree": String A: cat String B: tree String C: tcraete As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": String A: cat String B: tree String C: catrtee Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

    Input

    The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

    Output

    For each data set, print: Data set n: yes if the third string can be formed from the first two, or Data set n: no if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

    Sample Input

    3
    cat tree tcraete
    cat tree catrtee
    cat tree cttaree

    Sample Output

    Data set 1: yes
    Data set 2: yes
    Data set 3: no

    /////******DP******///////
    #include<iostream>
    #include<string>
    using namespace std;
    bool flag;
    string s1,s2,s;
    
    void dp(int len1,int len2,int len)
    {
        if(flag)    return;
        if(len==-1)        {flag=1;return;}
        if((len1>=0) && (s1[len1]==s[len]))
            dp(len1-1,len2,len-1);
        if((len2>=0) && (s2[len2]==s[len]))
            dp(len1,len2-1,len-1);
        return;
    }
    
    int main()
    {
        int num;
        cin>>num;
        for(int i=1;i<=num;i++)
        {
            flag=0;
            cin>>s1>>s2>>s;
            dp(s1.size()-1,s2.size()-1,s.size()-1);
            if(flag)
                cout<<"Data set "<<i<<": yes"<<endl;
            else    
                cout<<"Data set "<<i<<": no"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    数据库秒级平滑扩容架构方案
    利用SQL索引提高查询速度
    SQL Server调优系列进阶篇(如何维护数据库索引)
    SQL Server调优系列进阶篇(如何索引调优)
    SQL语法集锦一:显示每个类别最新更新的数据
    TreeView中节点勾选设置
    C# WinForm捕获全局异常
    SQL SERVER 查询死锁
    DataTable导入到Excel文件
    Microsoft SyncToy 文件同步工具
  • 原文地址:https://www.cnblogs.com/tinyork/p/3427632.html
Copyright © 2011-2022 走看看