zoukankan      html  css  js  c++  java
  • HDUOJ Number Sequence 题目1005

    

    /*Number Sequence
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 127146    Accepted Submission(s): 30901
    Problem Description
    A number sequence is defined as follows:
    f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
    Given A, B, and n, you are to calculate the value of f(n).
    Input
    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
    Output
    For each test case, print the value of f(n) on a single line.
    Sample Input
    1 1 3
    1 2 10
    0 0 0
    Sample Output
    2
    5
    Author
    CHEN, Shunbao
    Source
    ZJCPC2004 
    Recommend
    JGShining   |   We have carefully selected several similar problems for you:  1008 1001 1003 1009 1012
    */
    #include<stdio.h>
    int main()
    {
        int a,b,i;
        long long f[55],n;
        while(1)
        { scanf("%d %d %lld",&a,&b,&n);
            if(a==0&&b==0&&n==0)break;
            f[1]=f[2]=1;
            for(i=3;i<=49;i++)
             f[i]=(a*f[i-1]+b*f[i-2])%7;
            printf("%d ",f[n%48]);
        }
        return 0;
    }/*Number Sequence
    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 127146 Accepted Submission(s): 30901
    Problem Description
    A number sequence is defined as follows:
    f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
    Given A, B, and n, you are to calculate the value of f(n).
    Input
    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
    Output
    For each test case, print the value of f(n) on a single line.
    Sample Input
    1 1 3
    1 2 10
    0 0 0
    Sample Output
    2
    5
    Author
    CHEN, Shunbao
    Source
    ZJCPC2004
    Recommend
    JGShining | We have carefully selected several similar problems for you: 1008 1001 1003 1009 1012
    */

    又一道找规律题目
    #include<stdio.h>
    int main()
    {
    int a,b,i;
    long long f[55],n;
    while(1)
    { scanf("%d %d %lld",&a,&b,&n);
    if(a==0&&b==0&&n==0)break;
    f[1]=f[2]=1;
    for(i=3;i<=49;i++)
    f[i]=(a*f[i-1]+b*f[i-2])%7;
    printf("%d ",f[n%48]);
    }
    return 0;
    }

  • 相关阅读:
    搭建Vmware Workstation 12 + Kylin 4.02(Ubuntu 16.04) + petalinux + Vivado
    dash 和 bash 切换
    centos的镜像下载
    docker部署redis,kafka
    Centos7下使用mail发送邮件配置
    实现内网主机既能访问yum源,又能curl通baidu,外网nginx的配置
    centos7下使用mysql离线安装包安装mysql5.7
    内网主机使用nginx代理访问阿里yum源
    配置阿里云yum源
    centos下查看cpu核数
  • 原文地址:https://www.cnblogs.com/tlnshuju/p/7096038.html
Copyright © 2011-2022 走看看