zoukankan      html  css  js  c++  java
  • Climbing Worm

    Problem Description
    An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
     
    Input
    There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
     
    Output
    Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
     
    Sample Input
    10 2 1 20 3 1 0 0 0
     
    Sample Output
    17 19
     
    Source
     
     
     
    水题。
    总长为n,上升一秒走u,休息一秒下降d.
    相当于每两秒走(u-d);
    先n-u,得到过了多少个u-d后超过n-u;
    int t=(n-u)/(u-d);
            if(t*(u-d)<(n-u)) t++;
            t*=2;
            t++;
    就是最后一秒可以一步到达~~~
    代码:
    复制代码
    #include<stdio.h>
    int main()
    {
    int n,u,d;
    while(scanf("%d%d%d",&n,&u,&d),n)
    {
    int t=(n-u)/(u-d);
    if(t*(u-d)<(n-u)) t++;
    t*=2;
    t++;
    printf("%d ",t);
    }
    return 0;
    }
    复制代码
  • 相关阅读:
    cookie会话技术
    Vue实现任务列表效果
    Vue实现选项卡效果
    数组API(2)
    数组常用API(1)
    sticky,粘性定位
    了解HTTP协议和TCP协议
    快速排序
    冒泡排序
    【译】x86程序员手册21-6.3.5为操作系统保留的指令
  • 原文地址:https://www.cnblogs.com/to-creat/p/4929387.html
Copyright © 2011-2022 走看看