zoukankan      html  css  js  c++  java
  • 1023 Have Fun with Numbers (20分)

    Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

    Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

    Input Specification:

    Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

    Output Specification:

    For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

    Sample Input:

    1234567899
    Sample Output:

    Yes
    2469135798

    思路

    高精度 X 低精度

    #include<iostream>
    #include<string>
    #include<vector>
    #include<algorithm>
    
    using namespace std;
    
    const int N = 30;
    
    vector<int> a;
    int st[N][2];
    
    int main(){
        string p;
        
        cin >> p;
        
        for(int i = p.size() - 1; i >= 0; i --) a.push_back(p[i] - '0'), st[p[i] - '0'][0] ++;
        
        int x = 0;
        for(int i = 0; i < a.size(); i ++){
            a[i] = a[i] * 2 + x;
            x = a[i] / 10;
            a[i] %= 10;
        }
        
        if(x) a.push_back(x);
        reverse(a.begin(), a.end());
    
        int flag = 0;
        
        for(auto t : a) st[t][1] ++;
        
        for(int i = 0; i < 10; i ++)
            if(st[i][1] != st[i][0]){
                flag = 1;
                break;
            }
        
        if(flag) puts("No");
        else puts("Yes");
        for(auto t : a) cout << t;
        return 0;
    }
    
  • 相关阅读:
    在IDEA通过Maven构建Scala项目
    6.Pair RDD操作
    5.RDD的Action操作和持久化persist()
    29.Spark SQL发展史
    AirFlow初始化的时候遇到 Global variable explicit_defaults_for_timestamp needs to be on (1) for mysql
    4.RDD操作之Transform
    3.RDD详解和创建RDD方式
    28.Spark中action的介绍
    2.Spark 2.x 集群部署和测试
    Repeater分页
  • 原文地址:https://www.cnblogs.com/tomori/p/13427826.html
Copyright © 2011-2022 走看看