zoukankan      html  css  js  c++  java
  • zoj 3878 Convert QWERTY to Dvorak【好坑的模拟】

    Convert QWERTY to Dvorak

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken Caps Lock key, so Edward never presses the broken Caps Lock key. Luckily, all the other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

    The QWERTY Layout and the Dvorak Layout are in the following:

    Qwerty Layout
    The QWERTY Layout

    Dvorak Layout
    The Dvorak Layout

    Input

    A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

    Output

    The Dvorak document.

    Sample Input

    Jgw Gqm Andpw a H.soav Patsfk f;doe
    Nfk Gq.d slpt a X,dokt vdtnsaohe
    Kjd yspps,glu pgld; aod yso kd;kgluZ
    1234567890
    `~!@#$%^&*()}"']_+-=ZQqWEwe{[|
    ANIHDYf.,bt/
    ABCDEFuvwxyz
    

    Sample Output

    Hi, I'm Abel, a Dvorak Layout user.
    But I've only a Qwerty keyboard.
    The following lines are for testing:
    1234567890
    `~!@#$%^&*()+_-={}[]:"'<>,.?/|
    ABCDEFuvwxyz
    AXJE>Ugk,qf;
    
    题意:输入上边键盘的字符,输出下边键盘对应位置的字符 注意对转义字符处理
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<math.h>
    #define INF 0x3f3f3f
    #define DD double
    #define MAX 110
    using namespace std;
    char a[MAX];
    char c;
    char str[]= {"-=_+qwertyuiop[]QWERTYUIOP{}asdfghjkl;'ASDFGHJKL:"zxcvbnm,./ZXCVBNM<>?"};
    char s[]= {"[]{}',.pyfgcrl/="<>PYFGCRL?+aoeuidhtns-AOEUIDHTNS_;qjkxbmwvz:QJKXBMWVZ"};
    int main()
    {
        while(scanf("%c",&c)!=EOF)
        {
        	int ok=0;
        	int len=strlen(str);
            for(int i=0; i<len; i++)
                if(str[i]==c)
                {
                	printf("%c",s[i]);
                	ok=1;
    			}
                if(!ok)
                printf("%c",c);
    	}
        return 0;
    }
    

      

  • 相关阅读:
    小程序登陆流程解析
    小程序连续点击bug解决
    小程序开发文本空格的添加
    微信小程序转支付宝小程序
    支付宝小程序开发入门
    微信小程序开发入门
    text属性
    小程序横向滚动
    will-change
    Docker 系列二(操作镜像).
  • 原文地址:https://www.cnblogs.com/tonghao/p/4748820.html
Copyright © 2011-2022 走看看