zoukankan      html  css  js  c++  java
  • hud1047 java大数忽略空格

    Integer Inquiry

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10101    Accepted Submission(s): 2617


    Problem Description
    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
     

    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

    The final input line will contain a single zero on a line by itself.
     

    Output
    Your program should output the sum of the VeryLongIntegers given in the input. 


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     

    Sample Input
    1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
     

    Sample Output
    370370367037037036703703703670
    package com.acm.vivi;
    
    import java.math.BigInteger;
    import java.util.Scanner;
    
    public class Main {
    	public static void main(String []args)throws Exception{
    		Scanner cin = new Scanner(System.in);
    		int t = cin.nextInt();
    		while(t--!=0){
    		BigInteger sum = BigInteger.ZERO;
    		while(true){
    			String s = cin.next();
    			if(s.equals("0"))
    				break;
    			sum=sum.add(new BigInteger(s));
    		}
    		System.out.println(sum);
    		if(t>0)
    			System.out.println();
    		}
    		cin.close();
    	}
    }
    

    //java输入就不用考虑空行了
  • 相关阅读:
    使用Git--将本地项目提交到Github
    海量数据处理面试题
    web前后端安全问题
    mysql关键字如何当字段使用
    一个Java项目开发流程(正规级别)
    开发工具idea中撤回代码和恢复撤销代码快捷键
    layui前端使用
    shiro标签
    常见SVN图标的含义
    最常见到的runtime exception 异常
  • 原文地址:https://www.cnblogs.com/unclejelly/p/4082109.html
Copyright © 2011-2022 走看看