zoukankan      html  css  js  c++  java
  • Hat’s Words

    Hat’s Words

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5620    Accepted Submission(s): 2091

    Problem Description
    A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
    You are to find all the hat’s words in a dictionary.
     

    Input
    Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
    Only one case.
     

    Output
    Your output should contain all the hat’s words, one per line, in alphabetical order.
     

    Sample Input
    a ahat hat hatword hziee word
     

    Sample Output
    ahat hatword
     
    字典树题目,WA了,10次,好多细节要考虑。哎,学习了。ACM要靠经验哦。
    #include <iostream>
    #include <string>
    #include <vector>
    using namespace std;
    vector<string> hat;
    struct dictree
    {
    	dictree *child[26];
    	bool final;
    	dictree()
    	{
    		memset(child,0,sizeof(child));
    		final=false;
    	}
    };
    dictree *root;
    void insert(string source)
    {
    	dictree *current,*newnode;
    	int len = source.length();
    	if(!len)
    		return ;
    	current = root;
    	for(int i=0;i<len;i++)
    	{
    		if(current->child[source[i]-'a']==0)
    		{
    			newnode = new dictree();
    			current->child[source[i]-'a']=newnode;
    		}
    			current=current->child[source[i]-'a'];
    	}
    	current->final=true;
    }
    bool find(string source)
    {
    	dictree *current=root;
    	for(int i=0;i<(int)source.size();i++)
    	{
    		if(current->child[source[i]-'a']!=0)
    			current = current->child[source[i]-'a'];
    		else
    			return false;/*注意这个判断,WA了好几次的罪魁祸首啊。因为若少此一句,如果在某个终止结点处,source还没遍历完但是下一个不匹配。就会跳过这个字符去匹配下一个,好坑啊*/
    	}
    	return current->final;
    }
    int main()
    {
    	string temp;
    	root=new dictree();
    	while(cin>>temp)
    	{
    		insert(temp);
    		hat.push_back(temp);
    	}
    	for(int j=0;j<(int)hat.size();j++)
    	{
    		string t=hat[j];
    		unsigned len=t.size();
    		for(int i=1;i!=len;i++)
    		{
    			string s1(t,0,i);
    			string s2(t,i);
    			if(find(s1)&&find(s2))
    			{
    					cout<<hat[j]<<endl;
    					break;/*当满足条件是立刻跳出,否则可能会多次输出同一个
    			}
    		}
    	}
    	return 0;
    }


  • 相关阅读:
    C#操作Word (2)-- 打开&关闭Word文档
    JS input 银行卡号格式转换
    解决H5在微信浏览器或QQ浏览器修改title的问题
    CSS
    Atom 编辑器使用和学习
    php的一个小坑,输出不了json_encode
    js 组合键监听ctrl + enter
    webpack3.0 环境搭建
    css 使表格随着内容自动适应宽度
    获取input光标的x和y轴
  • 原文地址:https://www.cnblogs.com/unclejelly/p/4082144.html
Copyright © 2011-2022 走看看