zoukankan      html  css  js  c++  java
  • 紫书例题Ancient Cipher

    Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher. Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in the alphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”. Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation ⟨2, 1, 5, 4, 3, 7, 6, 10, 9, 8⟩ to the message “VICTORIOUS” one gets the message “IVOTCIRSUO”. It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination of the ciphers described above one gets the message “JWPUDJSTVP”. Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one. Input Input file contains several test cases. Each of them consists of two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet. The lengths of both lines of the input file are equal and do not exceed 100. Output For each test case, print one output line. Output ‘YES’ if the message on the first line of the input file could be the result of encrypting the message on the second line, or ‘NO’ in the other case.

    Sample Input

    JWPUDJSTVP

    VICTORIOUS

    MAMA ROME

    HAHA

    HEHE

    AAA

    AAA

    NEERCISTHEBEST

    SECRETMESSAGES

    Sample Output

    YES

    NO

    YES

    YES

    NO

    #include<iostream>
    #include<algorithm>
    #include<map>
    #include<stack>
    #include<queue>
    #include<vector>
    #include<set>
    #include<string>
    #include<cstdio>
    #include<cstring>
    #include<cctype>
    #include<cmath>
    using namespace std;
    
    int main()
    {
        int i;
        char cnt1[105],cnt2[105];
        int num1[26]={0},num2[26]={0};
        while(cin>>cnt1>>cnt2){
            int fla=0;
            memset(num1,0,sizeof(num1));
            memset(num2,0,sizeof(num2));
    
            for(i=0;i<strlen(cnt1);i++){
            num1[cnt1[i]-'A']++;
            num2[cnt2[i]-'A']++;
        }
    sort(num1,num1+26);
    sort(num2,num2+26);
    for(i=0;i<26;i++){
        if(num1[i]!=num2[i]){
            fla=1;
        }
        }
    
        if(fla) cout<<"NO"<<endl;
        else
        cout<<"YES"<<endl;
    
    }return 0;
    }
    View Code

    水题,统计每个字母出现的个数就好

  • 相关阅读:
    JavaScript 为字符串添加样式 【每日一段代码80】
    JavaScript replace()方法 【每日一段代码83】
    JavaScript for in 遍历数组 【每日一段代码89】
    JavaScript 创建用于对象的模板【每日一段代码78】
    html5 css3 新元素简单页面布局
    JavaScript Array() 数组 【每日一段代码88】
    JavaScript toUTCString() 方法 【每日一段代码86】
    位运算
    POJ 3259 Wormholes
    POJ 3169 Layout
  • 原文地址:https://www.cnblogs.com/upstart/p/5983318.html
Copyright © 2011-2022 走看看