zoukankan      html  css  js  c++  java
  • find your present (感叹一下位运算的神奇)

    find your present (2)

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 21948    Accepted Submission(s): 8671


    Problem Description
    In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
     
    Input
    The input file will consist of several cases. 
    Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
     
    Output
    For each case, output an integer in a line, which is the card number of your present.
     
    Sample Input
    5
    1 1 3 2 2
    3
    1 2 1
    0
     
    Sample Output
    3
    2
     
    Hint
     
    Hint
    use scanf to avoid Time Limit Exceeded
     
     
    //找出不同的那个数
    #include <bits/stdc++.h>
    using namespace std;
    int main()
    {
    	int i;
    	int n;
    	int temp;
    	int a;
    	while(scanf("%d",&n)!=EOF && n!=0)
    	{
    		temp=0;
    		while(n--)
    		{
    			scanf("%d",&a);
    			temp = a ^ temp;
    	    }
    	    cout<<temp<<endl;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    网络数据包分析工具列表
    完美支持Py3的微信开发库推荐
    微信后台服务器地址验证的逻辑
    人工智能头条技能树图谱汇集
    如何构建通用 api 中间层
    vue 2.0 购物车小球抛物线
    基于Vue的事件响应式进度条组件
    vuex学习总结
    vue 上传图片到阿里云(前端直传:不推荐)
    vue-router的history模式发布配置
  • 原文地址:https://www.cnblogs.com/upstart/p/6091359.html
Copyright © 2011-2022 走看看