zoukankan      html  css  js  c++  java
  • 完全背包 基础

    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

    InputThe input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
    OutputPrint exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
    Sample Input

    3
    10 110
    2
    1 1
    30 50
    10 110
    2
    1 1
    50 30
    1 6
    2
    10 3
    20 4

    Sample Output

    The minimum amount of money in the piggy-bank is 60.
    The minimum amount of money in the piggy-bank is 100.
    This is impossible.


    题意:题意大概就是说,有一个储钱罐,初始重量为e,最大重量为f,给出几种货币,有重量和对应的价值,求储钱罐最少有多少钱。
    思路:完全dp

    核心代码

    for (i = 1; i <= n; ++i) {
        for (j = w[i]; j <= f - e; ++j) {
            dp[j] = Math.min(dp[j], dp[j - w[i]] + p[i]);
        }
    }    

    代码:

    import java.util.Arrays;
    import java.util.Scanner;
    
    public class A {
        private static final int INF = 0x7ffffff;
        static Scanner sc = new Scanner(System.in);
    
        public static void main(String[] args) {
            int dp[] = new int[10010];
            int e, n, f, i, k, j;
            int w[] = new int[10050];
            int p[] = new int[10050];
            int T = sc.nextInt();
            while (T-- > 0) {
                e = sc.nextInt();
                f = sc.nextInt();
                n = sc.nextInt();
                for (i = 1; i <= n; ++i) {
                    p[i] = sc.nextInt();
                    w[i] = sc.nextInt();
                }
                Arrays.fill(dp, INF);
                dp[0] = 0;
                for (i = 1; i <= n; ++i) {
                    for (j = w[i]; j <= f - e; ++j) {
                        dp[j] = Math.min(dp[j], dp[j - w[i]] + p[i]);
                    }
                }
                if (dp[f - e] != INF)
                    System.out.println("The minimum amount of money in the piggy-bank is " + dp[f - e] + ".");
                else
                    System.out.println("This is impossible.");
    
            }
        }
    }



  • 相关阅读:
    Java关键字——instanceof
    C#基础知识整理 IList接口——非泛型
    .Net 中HashTable,HashMap 和 Dictionary<key,value> 和List<T>和DataTable的比较
    JS 判断是否为null
    java数组与字符串相互转换、整型与字符串相互转换
    数组元素的反转
    IOS系统中点击失效
    vue中计算属性和方法的区别,演示代码
    VUE中使用的插件有哪些?为什么,不能自动补全,script,methods和export default?
    【VueJS】实例中data属性的三种写法及区别
  • 原文地址:https://www.cnblogs.com/upstart/p/6701037.html
Copyright © 2011-2022 走看看