zoukankan      html  css  js  c++  java
  • Pick apples 第三届acm省赛

    Description

    Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because she has never seen so many apples before. Each kind of apple has a size and a price to be sold. Now the little girl wants to gain more profits, but she does not know how. So she asks you for help, and tell she the most profits she can gain.

    Input

    In the first line there is an integer T (T <= 50), indicates the number of test cases.
    In each case, there are four lines. In the first three lines, there are two integers S and P in each line, which indicates the size (1 <= S <= 100) and the price (1 <= P <= 10000) of this kind of apple.

    In the fourth line there is an integer V,(1 <= V <= 100,000,000)indicates the volume of the girl's bag.

    Output

    For each case, first output the case number then follow the most profits she can gain.

    Sample Input

    1
    1 1
    2 1
    3 1
    6
    

    Sample Output

    Case 1: 6

    #include <iostream>
    #include <stdio.h>
    #include <algorithm>
    using namespace std;
    struct N
    {
        int s,p;
        double pri;
    } node[4];
    bool cmp(N a,N b)
    {
        if(a.pri<b.pri)        return true;
        return false;
    }
    long long llmax(long long a,long long b)
    {
        return a>b?a:b;
    }
    int main()
    {
        int t;
        cin>>t;
        int c=1;
        while(t--)
        {
            for(int i=0;i<3;i++){
                cin>>node[i].s>>node[i].p;
                node[i].pri = 1.0*node[i].s/(1.0*node[i].p);
            }
            int V;
            cin>>V;
            sort(node,node+3,cmp);
            long long ans=0;
            for(int i=0; i<node[0].s; i++)
            {
                for(int j=0; j<node[0].s; j++)
                {
                    long long temp=i*node[1].s+j*node[2].s;
                    if(temp>V)
                        break;
                    else
                    {
                        long long v=V-temp;
                        ans=llmax(ans,v/node[0].s*node[0].p+i*node[1].p+j*node[2].p);
                    }
                }
            }
            cout<<"Case "<<c++<<": "<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Elasticsearch入门系列(一)
    清楚Chrome缓存
    解决IIS启动站点报错
    Input type="file"上传文件change事件只触发一次解决方案
    本地计算机上的XXX服务启动后停止,某些服务在未由其它服务或程序使用时将自动停止
    SQL Server Datetime类型为NULL不能用ISNULL(datetime,' ')来判断,会导致1900-01-01
    浏览指南
    谁发明的c++
    c++的用处
    不一样的二叉树遍历(小学生都会)
  • 原文地址:https://www.cnblogs.com/upstart/p/6783571.html
Copyright © 2011-2022 走看看