zoukankan      html  css  js  c++  java
  • Frog FZU

    Frog

     FZU - 2272 

    Therearex frogs and y chicken in a garden. Kim found there are n heads and m legs in the garden. Please tell Kim how many frogs and chicken are there. (A frog has 4 legs, and a chicken has 2 legs.)

    Input

    First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.

    For each test case: Two number n and m.

    1<=n, m <=100000. The data is legal.

    Output

    For each test case, output two numbers A and B – the number of frog and the number of chicken.

    Sample Input

    2
    2 6
    2 4
    

    Sample Output

    1 1
    0 2

    #include <iostream>
    #include <cstdio>
    #include <sstream>
    #include <cstring>
    #define MOD 2017
    #define LL long long
    #define ULL unsigned long long
    #define INF 0x3f3f3f3f
    #define maxn 100009
    #define Pair pair<int, int>
    #define mem(a, b) memset(a, b, sizeof(a))
    #define _  ios_base::sync_with_stdio(0),cin.tie(0)
    using namespace std;
    
    int main()
    {
        LL T,n,m;
        cin>>T;
        while(T--)
        {
           cin>>n>>m;
           cout<<m/2 - n<<" "<<2 * n - (m / 2)<<endl;
    
        }
        return 0;
    }
  • 相关阅读:
    oc结构
    iOS分类
    iOS协议
    缓存无底洞现象
    数据库备份,恢复
    PHP邮件发送库:Swiftmailer
    PHP分页组件:Paginator
    PHP验证码类
    PHP日期和时间处理组件-Carbon
    composer的一些操作
  • 原文地址:https://www.cnblogs.com/upstart/p/8982286.html
Copyright © 2011-2022 走看看