zoukankan      html  css  js  c++  java
  • 和風いろはちゃんイージー / Iroha and Haiku (ABC Edition) AtCoder

    和風いろはちゃんイージー / Iroha and Haiku (ABC Edition)

     AtCoder - 1977 

     Problem Statement

     

    Iroha loves Haiku. Haiku is a short form of Japanese poetry. A Haiku consists of three phrases with 57 and 5 syllables, in this order.

    To create a Haiku, Iroha has come up with three different phrases. These phrases have AB and C syllables, respectively. Determine whether she can construct a Haiku by using each of the phrases once, in some order.

    Constraints

     

    • 1≦A,B,C≦10

    Input

     

    The input is given from Standard Input in the following format:

    A B C
    

    Output

     

    If it is possible to construct a Haiku by using each of the phrases once, print YES(case-sensitive). Otherwise, print NO.

    Sample Input 1

     

    5 5 7
    

    Sample Output 1

     

    YES
    

    Using three phrases of length 55 and 7, it is possible to construct a Haiku.

    Sample Input 2

     

    7 7 5
    

    Sample Output 2

     

    NO
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<cmath>
    #include<utility>
    #include<set>
    #include<vector>
    #include<map>
    #include<queue>
    #include<stack>
    #define maxn 1010
    #define INF 0x3f3f3f3f
    #define LL long long
    #define ULL unsigned long long
    #define E 1e-8
    #define mod 1000000007
    #define P pair<int,int>
    using namespace std;
    int main()
    {
        int a[3];
        while(cin>>a[0]>>a[1]>>a[2])
            {
                int sum = 0,sum2 = 0;
            for(int i=0;i<3;i++){
                if(a[i] == 5)
                sum++;
            else
                if(a[i] == 7)
                sum2++;
            }
            if((sum == 2) && (sum2 == 1))
                cout << "YES" <<endl;
            else
                cout<<"NO"<<endl;
        }
    }
  • 相关阅读:
    JavaScript闭包 懂不懂由你反正我是懂了
    浅析对象访问属性的"."和"[]"方法区别
    PHP:6种GET和POST请求发送方法
    ArcThemALL!5.1:解压、脱壳、压缩样样精通
    nw.exe开发DEMO下载
    解析Javascript事件冒泡机制
    node.js之fs模块
    Node.js读取文件内容
    php-编译模块1
    jenkins--使用命令行自动启动Jenkins的job
  • 原文地址:https://www.cnblogs.com/upstart/p/8982409.html
Copyright © 2011-2022 走看看