zoukankan      html  css  js  c++  java
  • HDU 1212 Big Number

                 HDU 1212 Big Number

              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                   Total Submission(s): 9158    Accepted Submission(s): 6214


    Problem Description
    As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
    To make the problem easier, I promise that B will be smaller than 100000.
    Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
     
    Input
    The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
     
    Output
    For each test case, you have to ouput the result of A mod B.
     
    Sample Input
    2 3
    12 7
    152455856554521 3250
     
    Sample Output
    2
    5
    1521
     
    思路:大数求余:
            ( a + b ) % c = ( ( a % c) + ( b % c ) ) % c;
            ( a * b ) % c = ( ( a % c ) * ( b % c ) ) % c;
     
    (来自 百度文库 https://wenku.baidu.com/view/3784592beefdc8d376ee32ba.html )
    #include<iostream>
    #include<string>
    using namespace std;
    int main() {
        int n, i, j;
        string s;
        while(cin>>s>>n) {
            j = 0;
            for(i = 0; i < s.length(); i++) {
                j = ( j*10 % n + (s[i]-'0')%n ) % n;
            }
            cout<<j<<endl;
        }
        return 0;
    }
  • 相关阅读:
    MIB Browser使用方法
    RestTemplate调用https接口跳过证书验证
    Looper&Handler
    Thread类以及常见得同步类
    Android 关键类(RefBase,sp, wp)
    JNI
    binder
    struct enum union区别
    Q_PROPERTY
    linux 命令
  • 原文地址:https://www.cnblogs.com/v-vip/p/8709455.html
Copyright © 2011-2022 走看看