zoukankan      html  css  js  c++  java
  • 1036 Boys vs Girls (25 分)

    1. 题目

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeFgradeM. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA
    

    2. 题意

    输入n名学生(信息包含:姓名、性别、学号、成绩),找出学生中,女生成绩最高和男生成绩最低的两位,并输出两人的成绩差。如果n名学生中没有男生或女生,输出Absent,且成绩差输出NA

    3. 思路——简单模拟

    1. 学生信息用结构体存储

    2. 初始时女生最高成绩为-1,这样只要有女生成绩比其高,就会更新;

      同理初始时男生最低成绩为101,这样只要只要男生成绩比其低,就会更新;

      如果最后最高成绩依旧为-1,说明n名学生中没有女生;

      如果最后最低成绩依旧为101,说明n名学生中没有男生。

    4. 代码

    #include <iostream>
    #include <string>
    
    using namespace std;
    
    // 构建一个学生信息结构体,包含姓名、性别、ID号、成绩相关信息 
    typedef struct stu
    {
    	string name;
    	char gender;
    	string ID;
    	int grade;
    } Stu;
    
    int main()
    {
    	int n;
    	cin >> n;
    
    	Stu student;
    	Stu femaleRes, maleRes;
    	// 因为女生要找成绩最大值,将其grade置为-1,凡是成绩大于-1即更新女生结果 
    	femaleRes.grade = -1;
    	// 因为男生要找成绩最小值,将其grade置为101,凡是成绩小于101即更新男生结果 
    	maleRes.grade = 101;
    	while (n--)
    	{
    		cin >> student.name >> student.gender >> student.ID >> student.grade;
    		if (student.gender == 'F')
    		{
    			if (student.grade > femaleRes.grade)
    				femaleRes = student;
    		} else
    		{
    			if (student.grade < maleRes.grade)
    				maleRes = student;
    		}
    	}
    	// 这里通过看男女生成绩是否还是-1或101, 来判断学生列表中国是否 
    	if (femaleRes.grade == -1) cout << "Absent" << endl;
    	else cout << femaleRes.name	<< " " << femaleRes.ID << endl;
    	if (maleRes.grade == 101) cout << "Absent" << endl;
    	else cout << maleRes.name << " " << maleRes.ID << endl;
    	if (femaleRes.grade	!= -1 && maleRes.grade != 101)
    		cout << femaleRes.grade	- maleRes.grade << endl;
    	else cout << "NA" << endl; 
    }
    
  • 相关阅读:
    PerfDog携手Imagination,助力开发者获取GPU关键数据
    WeTest云手机升级,支持iOS 15全新系统
    洞穿性能测试痛点,PerfDog以提升应用和游戏的品质为使命
    使用xmlhttprequest遇到CORS报错的处理
    Hive的联级(cascade)-新增字段(column)后,旧分区无法更新数据问题
    数据异常检测入门
    Linux查看文件或文件夹大小: du命令
    k8s pod自动重启原因(jvm内存设置)
    计算容器运行至今多长时间
    期刊论文在线投稿审稿系统day1数据库设计
  • 原文地址:https://www.cnblogs.com/vanishzeng/p/15478013.html
Copyright © 2011-2022 走看看