Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11692 Accepted Submission(s): 8275
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
没有分析,这就是明显用母函数的最简单的题,用模板就可以过
1 #include <iostream> 2 using namespace std; 3 const int _max = 10001; 4 int c1[_max], c2[_max]; 5 int main() 6 { 7 8 int nNum; 9 int i, j, k; 10 while(cin >> nNum) 11 { 12 for(i=0; i<=nNum; ++i) 13 { 14 c1[i] = 1; 15 c2[i] = 0; 16 } 17 for(i=2; i<=nNum; ++i) 18 { 19 for(j=0; j<=nNum; ++j) 20 for(k=0; k+j<=nNum; k+=i) 21 { 22 c2[j+k] += c1[j]; 23 } 24 for(j=0; j<=nNum; ++j) 25 c1[j] = c2[j]; 26 c2[j] = 0; 27 } 28 } 29 cout << c1[nNum] << endl; 30 } 31 return 0; 32 }