zoukankan      html  css  js  c++  java
  • [ACM] poj 2456 Aggressive cows (二分查找)

    Aggressive cows
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5436   Accepted: 2720

    Description

    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

    Input

    * Line 1: Two space-separated integers: N and C

    * Lines 2..N+1: Line i+1 contains an integer stall location, xi

    Output

    * Line 1: One integer: the largest minimum distance

    Sample Input

    5 3
    1
    2
    8
    4
    9

    Sample Output

    3

    Hint

    OUTPUT DETAILS:

    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

    Huge input data,scanf is recommended.

    Source

    解题思路:

    这道题虽然不长,可是读了好几遍才读懂。有n个牛舍,每个牛舍有自己的位置xi(可以理解为坐标),把c头牛放在这n个牛舍里面,要求最近的两头牛之间的最大距离。

    比如测试数据 5个牛舍 3头牛 牛舍坐标1 2 8 4 9

    先按贪心,第一头牛肯定被放在第一个牛舍里,排序 1 2 4 8 9

    第二头牛可以放在2,也可以放在4,假设第二头牛放在2 ,与第一头牛的距离为1 ,假设第三头放在9,与第二头的距离为7,那么,最近的两头牛之间的最大距离为1

    最有解为 第一头牛放在1  第二头牛放在4 ,第三头牛放在9 ,那么 4-1=3  9-4=5 ,最近的两头牛之间的最大距离为3

    也就是求相邻两头牛之间距离的最小值(取最大)。这个距离采用二分的形式进行判断。

    代码:

    #include <iostream>
    #include <stdio.h>
    #include <algorithm>
    using namespace std;
    const int maxn=100002;
    const int inf=0x7fffffff;
    int x[maxn];
    int n,c;
    
    bool ok(int m)
    {
        int last=0;
        for(int i=1;i<c;i++)
        {
            int cur=last+1;//cur指当前的牛舍位置
            while(cur<n&&x[cur]-x[last]<m)
                cur++;
            if(cur==n)//只放下第一头牛,无法放下第二头牛,使二者的距离大于等于m
                return false;
            last =cur;//把第i头牛放在编号为cur的牛舍里,这里牛的头数和牛舍的编号都是从0开始的
        }
        return true;
    }
    int main()
    {
        cin>>n>>c;
        for(int i=0;i<n;i++)
            scanf("%d",&x[i]);
        sort(x,x+n);
        int l=0,r=inf;//这里r也可以写成题目里的最大距离1000000000
        for(int i=0;i<100;i++)
        {
            int m=(l+r)/2;
            if(ok(m))
                l=m;
            else r=m;
        }
        cout<<l<<endl;
        return 0;
    }
    


     

  • 相关阅读:
    图片懒加载DEMO
    手写offset函数
    DOM
    jQuery笔记
    children和 childNodes辨析
    运算符...典型的三种用处
    Python中的数据结构---栈,队列
    手写call方法
    移动零元素--leetcode题解总结
    剑指 Offer 36. 二叉搜索树与双向链表
  • 原文地址:https://www.cnblogs.com/vivider/p/3697488.html
Copyright © 2011-2022 走看看